libomxil: update to 0.9.2.1
[openembedded.git] / recipes / ddclient / ddclient_3.6.3.bb
blob6f770b8fe5d3ae8df455d0f419218c40ff8600ed
1 SECTION = "console/network"
2 DESCRIPTION = "Ddclient is a Perl client used to update dynamic DNS entries for accounts on Dynamic DNS Network Services"
3 HOMEPAGE = "http://ddclient.sourceforge.net/"
4 LICENSE = "GPL"
5 PR = "r4"
7 SRC_URI = "\
8 ${SOURCEFORGE_MIRROR}/ddclient/ddclient-${PV}.tar.bz2 \
9 file://ip-up"
11 RDEPENDS_${PN} = "perl perl-module-strict perl-module-getopt-long perl-module-vars perl-module-warnings-register perl-module-warnings perl-module-carp perl-module-exporter perl-module-constant perl-module-exporter-heavy perl-module-sys-hostname perl-module-xsloader perl-module-autoloader perl-module-io-socket perl-module-io-handle perl-module-symbol perl-module-selectsaver perl-module-io perl-module-socket perl-module-errno perl-module-config perl-module-io-socket-inet perl-module-io-socket-unix perl-module-integer perl-module-overload"
13 do_install() {
14 install -d ${D}${sbindir} ${D}${sysconfdir}/ddclient ${D}${sysconfdir}/init.d
15 install -d ${D}${sysconfdir}/ppp/ip-up.d/ install -d ${D}${docdir}/ddclient
16 install -m 755 ${S}/ddclient ${D}${sbindir}
17 install ${S}/sample-etc_ddclient.conf ${D}${sysconfdir}/ddclient/ddclient.conf
18 install -m 755 ${WORKDIR}/ip-up ${D}${sysconfdir}/ppp/ip-up.d/ddclient
19 sed -e 's|/etc/ddclient.conf|/etc/ddclient/ddclient.conf|g' ${S}/sample-etc_rc.d_init.d_ddclient > ${S}/rc_init
20 install -m 755 ${S}/rc_init ${D}${sysconfdir}/init.d/ddclient
21 install ${S}/README* ${D}${docdir}/ddclient
22 install ${S}/COPY* ${D}${docdir}/ddclient
23 install ${S}/sample* ${D}${docdir}/ddclient
26 CONFFILES_${PN} = "${sysconfdir}/ddclient/ddclient.conf"
28 SRC_URI[md5sum] = "42a3a420e492c0111adc58ac08ff6d04"
29 SRC_URI[sha256sum] = "28be7102bde3bc9b39be2732b89da9fbab79b7ac3898075ed414a45258bb3026"