mesa-7.9: bump PR after talloc changes
[openembedded.git] / recipes / rxvt / rxvt_2.7.9.bb
blobf4840b7a165ecc6217688e1f99710a27f73210e4
1 DESCRIPTION = "Well known terminal emulator"
2 SECTION = "x11/utils"
3 PR = "r1"
4 DEPENDS = "virtual/libx11 libxft"
5 LICENSE = "GPL"
6 SRC_URI = "${HANDHELDS_CVS};module=apps/rxvt \
7 file://include.patch"
9 inherit autotools update-alternatives
11 ALTERNATIVE_NAME = "x-terminal-emulator"
12 ALTERNATIVE_PATH = "${bindir}/rxvt-2.7.9"
14 S = "${WORKDIR}/rxvt"
16 EXTRA_OECONF = "--disable-menubar --disable-xim \
17 --enable-utmp --enable-wtmp --enable-lastlog \
18 --disable-strings --with-term=rxvt --enable-keepscrolling \
19 --with-xft --with-name=rxvt --enable-frills \
20 --enable-swapscreen --enable-transparency \
21 --with-codesets=eu,jp \
22 --enable-cursor-blink --enable-pointer-blank \
23 --enable-text-blink --enable-plain-scroll \
24 --enable-combining --enable-shared \
25 --with-x=${STAGING_LIBDIR}/.."
27 EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
28 'XLIB=-L${STAGING_LIBDIR} -lX11 -lXft'"
30 do_configure () {
31 mv autoconf/configure.in . || true
32 rm autoconf/libtool.m4
33 libtoolize --force
34 autotools_do_configure
35 echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
36 echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
37 echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
38 echo '#define HAVE_XLOCALE 1' >> config.h
39 echo '#define HAVE_UTMP_H 1' >> config.h
40 echo '#define HAVE_TTYSLOT 1' >> config.h