mesa-7.9: bump PR after talloc changes
[openembedded.git] / recipes / python / python-twisted_8.2.0.bb
blob3f8b657715e46ab39da50f3a8606f0cf81b1ea3c
1 DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
2 Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \
3 (including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4 HOMEPAGE = "http://www.twistedmatrix.com"
5 SECTION = "console/network"
6 PRIORITY = "optional"
7 LICENSE = "LGPL"
8 PR = "r3"
10 SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/8.2/Twisted-${PV}.tar.bz2 "
11 S = "${WORKDIR}/Twisted-${PV}"
13 inherit setuptools
15 PACKAGES += "\
16 ${PN}-zsh \
17 ${PN}-test \
18 ${PN}-protocols \
19 ${PN}-bin \
20 ${PN}-conch \
21 ${PN}-lore \
22 ${PN}-mail \
23 ${PN}-names \
24 ${PN}-news \
25 ${PN}-runner \
26 ${PN}-web \
27 ${PN}-words \
28 ${PN}-flow \
29 ${PN}-pair \
30 ${PN}-core \
33 RDEPENDS_${PN} = "python-core python-zopeinterface"
34 RDEPENDS_${PN} += "\
35 ${PN}-bin \
36 ${PN}-conch \
37 ${PN}-lore \
38 ${PN}-mail \
39 ${PN}-names \
40 ${PN}-news \
41 ${PN}-runner \
42 ${PN}-web \
43 ${PN}-words \
46 do_install_append() {
47 # remove some useless files before packaging
48 find ${D} -name "*.bat" -o -name "*.c" -o -name "*.h" -exec rm {} \;
51 ALLOW_EMPTY = "1"
52 FILES_${PN} = ""
54 FILES_${PN}-test = " \
55 ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
56 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
59 FILES_${PN}-protocols = " \
60 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/ \
63 FILES_${PN}-zsh = " \
64 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
65 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
68 FILES_${PN}-bin = " \
69 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/_c_urlarg.so \
70 ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/cBanana.so \
73 FILES_${PN}-conch = " \
74 ${bindir}/ckeygen \
75 ${bindir}/tkconch \
76 ${bindir}/conch \
77 ${bindir}/conchftp \
78 ${bindir}/cftp \
79 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
80 ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \
83 FILES_${PN}-core = " \
84 ${bindir}/manhole \
85 ${bindir}/mktap \
86 ${bindir}/twistd \
87 ${bindir}/tap2deb \
88 ${bindir}/tap2rpm \
89 ${bindir}/tapconvert \
90 ${bindir}/tkmktap \
91 ${bindir}/trial \
92 ${bindir}/easy_install* \
93 ${bindir}/pyhtmlizer \
94 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
95 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
96 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
97 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \
98 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \
99 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \
100 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \
101 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \
102 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \
103 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \
104 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \
105 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \
106 ${libdir}/${PYTHON_DIR}/site-packages/twisted/application \
107 ${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \
108 ${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \
109 ${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \
110 ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
111 ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
112 ${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \
113 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\
114 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python\
115 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \
116 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \
117 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \
118 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \
119 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \
120 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \
121 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
122 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
123 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
124 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
125 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
126 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
127 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
128 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
129 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
130 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
131 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
132 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
133 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
134 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
135 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
136 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
137 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
138 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
139 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
140 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
141 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
142 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
143 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
144 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
145 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
146 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
147 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
148 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
149 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
150 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
151 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
152 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
153 ${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
154 ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
155 ${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
156 ${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
157 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
158 ${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
159 ${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
160 ${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
161 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
162 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
163 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
166 FILES_${PN}-lore = " \
167 ${bindir}/bookify \
168 ${bindir}/lore \
169 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_lore.py* \
170 ${libdir}/${PYTHON_DIR}/site-packages/twisted/lore \
173 FILES_${PN}-mail = " \
174 ${bindir}/mailmail \
175 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \
176 ${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \
179 FILES_${PN}-names = " \
180 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \
181 ${libdir}/${PYTHON_DIR}/site-packages/twisted/names \
184 FILES_${PN}-news = " \
185 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \
186 ${libdir}/${PYTHON_DIR}/site-packages/twisted/news \
189 FILES_${PN}-runner = " \
190 ${libdir}/site-packages/twisted/runner/portmap.so \
191 ${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\
194 FILES_${PN}-web = " \
195 ${bindir}/websetroot \
196 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \
197 ${libdir}/${PYTHON_DIR}/site-packages/twisted/web\
200 FILES_${PN}-words = " \
201 ${bindir}/im \
202 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
203 ${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
206 FILES_${PN}-flow = " \
207 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \
208 ${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \"
210 FILES_${PN}-pair = " \
211 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \
212 ${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \
215 FILES_${PN}-dbg += " \
216 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
217 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
220 SRC_URI[md5sum] = "c85f151999df3ecf04c49a781b4438d2"
221 SRC_URI[sha256sum] = "e0602bb05e31f6100b6f9ab35cfa93ab9f7a1c50a351a0ddfcd236a923bddfb0"