mesa-7.9: bump PR after talloc changes
[openembedded.git] / recipes / python / python-numpy_1.1.1.bb
blobf5c23e055f1df69922146658bd2f111c5fba34bc
1 DESCRIPTION = "A sophisticated Numeric Processing Package for Python"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 LICENSE = "PSF"
5 PR = "ml0"
7 SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
8 file://unbreak-assumptions.diff \
9 file://trycompile.diff \
10 file://config.h \
11 file://numpyconfig.h \
14 S = "${WORKDIR}/numpy-${PV}"
16 inherit distutils
18 # Make the build fail and replace *config.h with proper one
19 # This is a ugly, ugly hack - Koen
20 do_compile_prepend() {
21 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
22 ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
23 true
24 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
29 SRC_URI[md5sum] = "af066b59a50bf5dbe1a14d6be3df6937"
30 SRC_URI[sha256sum] = "d430273a77aed959c007595d969fefa36c59249807212d7d89f5d6cf2a701dd6"