mesa-7.9: bump PR after talloc changes
[openembedded.git] / recipes / gnome-mplayer / gecko-mediaplayer_0.9.8.bb
blobe5cfb527996b4dee4177f6cb5478e59b3acd3c3d
1 DESCRIPTION = "Gecko plugin for gnome-mplayer"
2 HOMEPAGE = "http://dekorte.homeip.net/download/gecko-mediaplayer/"
3 LICENSE = "GPL"
4 DEPENDS = "firefox gtk+ gconf dbus-glib"
5 RDEPENDS_${PN} = "firefox gnome-mplayer"
7 PR = "r9"
9 inherit autotools
11 SRC_URI = "http://gecko-mediaplayer.googlecode.com/files/${P}.tar.gz \
12 file://gecko-mplayer-svn.diff;striplevel=0 \
13 file://extensions \
16 do_install_append() {
17 cp -PpR ${WORKDIR}/extens* ${D}${libdir}/mozilla/
20 PACKAGES =+ "${PN}-firefox-hack"
21 RDEPENDS_${PN}-firefox-hack = "${PN}"
22 FILES_${PN}-firefox-hack = "${libdir}/mozilla/extensions"
24 FILES_${PN} += "${sysconfdir}/* \
25 ${libdir}/mozilla/*"
26 FILES_${PN}-dbg += "${libdir}/mozilla*/plugins/.debug/*"
28 pkg_postinst_${PN}-firefox-hack() {
29 for firefoxdir in $D${libdir}/firefox-* ; do
30 if [ -e $firefoxdir/extensions/ ] ; then
31 ln -sf ${libdir}/mozilla/extensions/flash@alwaysinnovating.com $firefoxdir/extensions/
33 done
37 SRC_URI[md5sum] = "4df009d21b1a95c35c9adfdb6fbc96fe"
38 SRC_URI[sha256sum] = "a51ebf00021b1d5d43837edebd0fb28d8f6d2626111c4c391e8b0f6515004aa1"