gnome-screensaver 2.28.3: fix up configure as well now
[openembedded.git] / recipes / hal / hal_0.5.14+git.bb
blob1e1f10e01a85adf3d9c09b532a43b5d279a8946e
1 require hal.inc
3 DEFAULT_PREFERENCE = "-1"
4 DEFAULT_PREFERENCE_angstrom = "1"
6 SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
7 file://0001-Add-touchscreen-option.patch;patch=1 \
8 file://20hal \
9 file://99_hal"
11 SRCREV = "6dccf8e3ad181e8f56b1d2a994ec50a1953a1c2d"
13 PV = "0.5.14"
14 PR = "r2"
15 PR_append = "+gitr${SRCREV}"
17 S = "${WORKDIR}/git"
19 # The following code finds the right linux/input.h,
20 # which also works with external-toolchain/SDK
21 do_configure() {
22 sed -i -e s:1.43:1.41:g ${S}/configure.in
23 linux_input_h=`echo "#include <linux/input.h>" | ${CPP} - | \
24 grep "linux\/input.h" | head -n 1 | awk -F '"' '{print $2}'`
25 autotools_do_configure --with-linux-input-header=${linux_input_h}