u-boot-mkimage-openmoko-native: Unused now, remove.
[openembedded.git] / recipes / meta / slugos-packages.bb
blob0e4ff8b9c67539467863da525ceb8225a247573a
1 # Meta package containing all the packages which build for SlugOS
3 # All packages in here must build with the slugos-???.conf distros,
4 # they do not necessarily work.
5 DESCRIPTION = "Packages that are compatible with the SlugOS firmware"
6 HOMEPAGE = "http://www.nslu2-linux.org"
7 LICENSE = "MIT"
8 PR = "r68"
9 CONFLICTS = "db3"
11 COMPATIBLE_MACHINE = "nslu2|ixp4xx"
12 EXCLUDE_FROM_WORLD = "1"
13 INHIBIT_DEFAULT_DEPS = "1"
14 ALLOW_EMPTY = "1"
16 # The list of packages to build for the slugos DISTRO.
17 # KEEP IN ALPHABETICAL ORDER
18 # Do *not* simply comment out a line. That will break. Instead
19 # remove the package and place it in the corresponding "broken" list
21 SLUGOS_PACKAGES = "\
22 alsa-lib \
23 alsa-utils \
24 apr \
25 asterisk \
26 asterisk-core-sounds-en-alaw \
27 asterisk-core-sounds-en-g729 \
28 asterisk-core-sounds-en-gsm \
29 asterisk-core-sounds-en-ulaw \
30 asterisk-extra-sounds-en-alaw \
31 asterisk-extra-sounds-en-g729 \
32 asterisk-extra-sounds-en-gsm \
33 asterisk-extra-sounds-en-ulaw \
34 asterisk-moh-freeplay-alaw \
35 asterisk-moh-freeplay-g729 \
36 asterisk-moh-freeplay-gsm \
37 asterisk-moh-freeplay-ulaw \
38 atftp \
39 audiofile \
40 aumix \
41 autoconf \
42 autofs \
43 automake \
44 bash \
45 beep \
46 bind \
47 binutils \
48 bison \
49 bluez-libs \
50 bogofilter \
51 bonnie++ \
52 boost \
53 bridge-utils \
54 bwmon \
55 bzip2 \
56 ccxstream \
57 cdparanoia \
58 cdstatus \
59 cherokee \
60 coreutils \
61 cron \
62 cryptsetup \
63 curl \
64 cvs \
65 db \
66 dbus \
67 devio \
68 devlabel \
69 diffstat \
70 diffutils \
71 dircproxy \
72 dnsmasq \
73 dropbear \
74 e2fsprogs \
75 expat \
76 ez-ipupdate \
77 fconfig \
78 fetchmail \
79 file \
80 findutils \
81 fis \
82 flac \
83 flex \
84 flite \
85 ftpd-topfield \
86 fuse \
87 gawk \
88 gcc \
89 gdb \
90 gdbm \
91 glib-2.0 \
92 gnu-config \
93 gphoto2 \
94 grep \
95 groff \
96 gtk-doc \
97 gzip \
98 hdparm \
99 hostap-daemon \
100 ifupdown \
101 iozone3 \
102 iperf \
103 ipkg-utils \
104 iptables \
105 joe \
106 jpeg \
107 kexec-tools \
108 lcdproc \
109 less \
110 libdvb \
111 libexif \
112 libid3tag \
113 liblockfile \
114 libmad \
115 libmikmod \
116 libogg \
117 libol \
118 libpam \
119 libpcre \
120 libpng \
121 libtool \
122 libupnp \
123 libusb1 libusb-compat \
124 libvorbis \
125 libxml2 \
126 lighttpd \
127 litestream \
128 logrotate \
129 lrzsz \
130 lsof \
131 m4 \
132 madplay \
133 mailx \
134 make \
135 man man-pages \
136 masqmail \
137 mdadm \
138 mediatomb \
139 memtester \
140 mgetty \
141 microcom \
142 minicom \
143 monit \
144 mt-daapd \
145 mtd-utils \
146 mutt \
147 mysql \
148 nail \
149 nano \
150 ncftp \
151 ncurses \
152 net-tools \
153 netcat \
154 nfs-utils \
155 ngrep \
156 nmap \
157 ntfs-3g \
158 ntp \
159 ntpclient \
160 openntpd \
161 openssh \
162 openvpn \
163 owfs \
164 patch \
165 pciutils \
166 perl \
167 picocom \
168 pkgconfig \
169 popt \
170 portmap \
171 ppp \
172 procps \
173 psmisc \
174 puppy \
175 python \
176 quilt \
177 rng-tools \
178 rsync \
179 samba \
180 screen \
181 sed \
182 setpwc \
183 setserial \
184 sipsak \
185 slugimage \
186 smartmontools \
187 spandsp \
188 sqlite \
189 squid \
190 sshfs-fuse \
191 ssmtp \
192 strace \
193 streamripper \
194 stunnel \
195 sudo \
196 sysfsutils \
197 syslog-ng \
198 tar \
199 tcpdump \
200 thttpd \
201 tiff \
202 tzdata \
203 unrar \
204 unzip \
205 upslug2 \
206 usbutils \
207 ushare \
208 util-linux-ng \
209 vim \
210 vlan \
211 vsftpd \
212 w3cam \
213 wakelan \
214 watchdog \
215 webcam-server \
216 wget \
217 wireless-tools \
218 wpa-supplicant \
219 wview-sim \
220 wview-vpro \
221 wview-wxt510 \
222 xinetd \
223 yp-tools ypbind ypserv \
224 zd1211-firmware \
225 zip \
226 zlib \
229 # Packages that may pull in X11 libs. We need to consider
230 # if these are practical.
231 SLUGOS_X11_PACKAGES = "\
232 bluez-hcidump \
233 bluez4 \
234 cups \
235 gpsd \
236 ircp \
237 libao \
238 mpd \
239 netatalk \
240 obexftp \
241 obexpush \
242 openobex-apps \
243 openobex \
244 rtorrent \
245 sane-backends \
246 task-mokogateway-everything \
247 wireshark \
250 # Packages that are broken but need to be fixed!
252 # - apex-env: gcc4.4
253 # - inetutils: gcc 4.4
254 # - lvm2: gcc 4.4 (suspected)
255 # - madwifi-ng: gcc 4.4 (and possibly other problems)
257 SLUGOS_BROKEN_BUT_NEED_FIXING_PACKAGES = "\
258 apex-env \
259 inetutils \
260 lvm2 \
261 madwifi-ng \
264 # Packages currently broken on all platforms
265 # Notes:
266 # ctrlproxy - dependency on tdb.h (part of samba but not packaged/staged).
268 SLUGOS_BROKEN_PACKAGES = "\
269 ctrlproxy \
270 ctorrent \
271 cyrus-imapd \
272 cyrus-sasl \
273 dsniff \
274 eciadsl \
275 gspcav1 \
276 irssi \
277 linphone \
278 lirc-modules lirc \
279 madfu \
280 miau \
281 motion \
282 netpbm \
283 openldap \
284 postfix \
285 pvrusb2-mci \
286 pwc \
287 qc-usb-messenger \
288 reiserfsprogs reiser4progs \
289 task-native-sdk \
290 unionfs-modules unionfs-utils \
291 wview-sim-mysql wview-wxt510-mysql wview-vpro-mysql \
292 yeaphone \
293 zd1211 \
296 SLUGOS_EXTRA_PACKAGES ?= ""
298 # The package-index at the end causes regeneration of the Packages.gz and
299 # other control files.
300 DEPENDS = "\
301 slugos-image \
302 slugos-native \
303 task-proper-tools \
304 ${SLUGOS_PACKAGES} \
305 ${SLUGOS_EXTRA_PACKAGES} \
306 package-index \
309 inherit meta
311 do_package_write_ipk() {