1 # Meta package containing all the packages which build
for OPLinux
and OPLinux uclibc distro
2 # Copyright
(C
) 2007, Stelios Koroneos
- Digital OPSiS
, All Rights Reserved
3 # Released under the MIT license
(see packages
/COPYING
)
4 DESCRIPTION
= "Packages that are compatible with the OPLinux distro"
5 HOMEPAGE
= "http://www.digital-opsis/oplinux"
8 PROVIDES
+= "${OPLINUX_IMAGENAME}-packages"
10 EXCLUDE_FROM_WORLD
= "1"
11 INHIBIT_DEFAULT_DEPS
= "1"
15 python __anonymous
() {
19 #Get all the packages we can build
/exist in OE
20 package_list
= bb.
data.getVar
('PACKAGES_LIST'
, d
) or "none"
21 package_list
=package_list.split
()
23 #Get the packages that are broken on all architectures
24 broken_package_list
= bb.
data.expand
('$
{OPLINUX_BROKEN_PACKAGES
}'
, d
)
26 # Get the arch we are building
for
27 building_arch
= bb.
data.getVar
('FEED_ARCH'
,d
)
29 #Now add the broken packages list the ones that fail
for the arch we build now
30 if (building_arch
=="i486") or (building_arch
=="i586") or (building_arch
=="i686"):
31 broken_package_list
= broken_package_list
+ bb.
data.expand
('$
{OPLINUX_BROKEN_PACKAGES_ARCH_x86
}'
, d
)
33 elif
(building_arch
=="ppc405"):
34 broken_package_list
= broken_package_list
+ bb.
data.expand
('$
{OPLINUX_BROKEN_PACKAGES_ARCH_PPC
}'
, d
)
36 elif
(building_arch
=="ppc603e"):
37 broken_package_list
= broken_package_list
+ bb.
data.expand
('$
{OPLINUX_BROKEN_PACKAGES_ARCH_POWERPC
}'
, d
)
40 for chk_package in package_list
:
42 if chk_package in broken_package_list
:
45 bb.
data.setVar
('DEPENDS'
, (bb.
data.getVar
('DEPENDS'
, d
) + chk_package
+" "), d
)
47 #add the OPLinux extra packages
to the DEPENDS list
48 bb.
data.setVar
('DEPENDS'
, (bb.
data.getVar
('DEPENDS'
, d
) + bb.
data.getVar
('OPLINUX_EXTRA_PACKAGES'
, d
)), d
)
51 bb.
data.setVar
('DEPENDS'
, (bb.
data.getVar
('DEPENDS'
, d
) + "package-index"), d
)
58 # The list of packages availiable
to OE
59 # KEEP IN ALPHABETICAL ORDER
60 # Do
*not* simply comment out a
line. That will break. Instead
61 # remove the package
and place it in the corresponding
"broken" list
349 reiserfsprogs reiser4progs \
363 wview-sim wview-vpro wview-wxt510 \
364 wview-sim-mysql wview-vpro-mysql \
379 yp-tools ypbind ypserv \
385 # Packages currently broken on all platforms
(glibc
)
386 OPLINUX_BROKEN_PACKAGES
= "irssi \
392 #Here we define the packages that are broken on a specific architecture
394 OPLINUX_BROKEN_PACKAGES_ARCH_x86
=" \
457 OPLINUX_BROKEN_PACKAGES_ARCH_PPC
= " \
507 OPLINUX_BROKEN_PACKAGES_ARCH_POWERPC
= " \
575 #Packages broken per machine
(if we ever need such a thing
)
576 OPLINUX_BROKEN_PACKAGES_append_x86
=" \
578 OPLINUX_BROKEN_PACKAGES_append_i586
-generic
=" \
580 OPLINUX_BROKEN_PACKAGES_append_i686
-generic
=" \
582 OPLINUX_BROKEN_PACKAGES_append_epia
=" \
584 OPLINUX_BROKEN_PACKAGES_append_wrap
= "\
588 OPLINUX_BROKEN_PACKAGES_append_magicbox
= "\
590 OPLINUX_BROKEN_PACKAGES_append_dht
-walnut
= "\
593 OPLINUX_BROKEN_PACKAGES_append_efika
= "\
599 OPLINUX_UCLIBC_UNSUPPORTABLE_PACKAGES
= "\
604 yp-tools ypbind ypserv \
607 # These packages work with glibc
, but break on uclibc.
608 OPLINUX_UCLIBC_BROKEN_PACKAGES
= "\
619 OPLINUX_UCLIBC_BROKEN_PACKAGES_append_x86
= "\
622 OPLINUX_UCLIBC_BROKEN_PACKAGES_append_epia
= "\
625 OPLINUX_UCLIBC_BROKEN_PACKAGES_append_wrap
= "\
628 OPLINUX_UCLIBC_BROKEN_PACKAGES_append_magicbox
= "\
631 OPLINUX_UCLIBC_BROKEN_PACKAGES_append_dht
-walnut
= "\
635 # Packages which build only with glibc
(some of these use internal
636 # glibc functions
and so will probably never run on uclibc
).
637 OPLINUX_BROKEN_PACKAGES_append_uclibc
-linux
= "\
638 ${OPLINUX_UCLIBC_UNSUPPORTABLE_PACKAGES} \
639 ${OPLINUX_UCLIBC_BROKEN_PACKAGES} \
644 #Any extra packages defined
646 OPLINUX_EXTRA_PACKAGES ?
= ""