1 # Meta package containing all the packages which build
for SlugOS
3 # All packages in here must build with the slugos
-???.conf distros
,
4 # they do
not necessarily work.
5 DESCRIPTION
= "Packages that are compatible with the Openprotium on the iomega Storcenter"
6 HOMEPAGE
= "http://www.openprotium.org"
10 PROVIDES
+= "${OPENPROTIUM_IMAGENAME}-packages"
12 EXCLUDE_FROM_WORLD
= "1"
13 INHIBIT_DEFAULT_DEPS
= "1"
18 # The list of packages
to build
for the slugos DISTRO.
19 # KEEP IN ALPHABETICAL ORDER
20 # Do
*not* simply comment out a
line. That will break. Instead
21 # remove the package
and place it in the corresponding
"broken" list
23 # deleted from
"base" as they don't immediately build...
39 # bluez
-utils
-nodbus \
48 # reiserfsprogs reiser4progs \
65 OPENPROTIUM_PACKAGES
= "\
185 # Packages currently broken on all platforms
186 SLUGOS_BROKEN_PACKAGES
= "\
196 # These packages will never build because uclibc lacks
(and always will lack
)
197 # appropriate support. This define is
for documentation of this fact
! The
198 # normal cause is that the package uses the
"NIS" interfaces
(once known as
199 # YP
- a trademark of BT which SUN used without license
- the missing
function
200 # calls often still have 'yp' in the name
).
202 # NOTE
: rng
-tools is only here
until argp
-standalone can be built
!
203 UCLIBC_UNSUPPORTABLE_PACKAGES
= "\
208 yp-tools ypbind ypserv \
211 # These packages work with glibc
, but break on uclibc.
212 UCLIBC_BROKEN_PACKAGES
= "\
223 # Packages which build only with glibc
(some of these use internal
224 # glibc functions
and so will probably never run on uclibc
).
225 SLUGOS_PACKAGES_append_linux
= "\
226 ${UCLIBC_UNSUPPORTABLE_PACKAGES} \
227 ${UCLIBC_BROKEN_PACKAGES} \
236 wview-sim wview-vpro wview-wxt510 \
237 wview-sim-mysql wview-vpro-mysql \
242 SLUGOS_PACKAGES_append_linux
-uclibc
= "\
245 # These packages are
not in the build because they have a significant compilation
246 # time
, add them
to SLUGOS_EXTRA_PACKAGES
if required
247 SLUGOS_OPTIONAL_PACKAGES
= "\
252 # you can place these in the top level openembedded
/conf
/distro
/openprotium.conf
253 # file
to fine
-tune what's happening
255 OPENPROTIUM_EXTRA_PACKAGES ?
= ""
257 # The package
-index at the
end causes regeneration of the Packages.gz
and
258 # other control files.
259 # openprotium
-native \
262 ${OPENPROTIUM_PACKAGES} \
263 ${OPENPROTIUM_EXTRA_PACKAGES} \