u-boot-mkimage-openmoko-native: Unused now, remove.
[openembedded.git] / recipes / man / man_1.5p.bb
blob70edf868386107b3f44b570d075f60155a73fa5a
1 LICENSE = "GPL"
2 SECTION = "base"
3 DESCRIPTION = "The man page suite, including man, apropos, \
4 and whatis consists of programs that are used to read most \
5 of the documentation available on a Linux system."
6 PR = "r5"
7 RDEPENDS_${PN} = "less groff"
9 # Note: The default man.conf uses wrong names for GNU eqn and troff,
10 # so we install our own
11 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/man/man-${PV}.tar.bz2 \
12 file://man.conf"
14 # Disable parallel make or it tries to link objects before they are built
15 PARALLEL_MAKE = ""
17 EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
18 GS = "-DGREPSILENT=\"q\""
19 DEFS = "-DUSG -DDO_COMPRESS ${GS}"
21 do_configure() {
22 # this doesn't support cross compilation, so it generates a
23 # bogus configuration
24 sed -i /^LDFLAGS/d src/Makefile.in
25 ./configure -d -confdir ${sysconfdir}
28 do_compile() {
29 # this fixes up the cross compilation by killing the bogus DEFS
30 (cd src; ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} \
31 makemsg.c -o makemsg)
32 oe_runmake 'DEFS=${DEFS}'
35 do_install() {
36 oe_runmake 'PREFIX=${D}' 'DEFS=${DEFS}' install
37 install -m 644 ${WORKDIR}/man.conf ${D}/etc
40 FILES_${PN} = "${bindir}/* ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
41 ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
42 /bin /sbin /lib/*/ /lib/*.so*"
44 SRC_URI[md5sum] = "3800006ccd2f1f16124a2ac3abf04b30"
45 SRC_URI[sha256sum] = "5431073fb315f9b8dd43f430d7a9082e0a6232e20af559604da573270df8236b"