2 # Copyright 2006-2008 OpenedHand Ltd.
7 BOOTSTRAP_EXTRA_RDEPENDS += "dpkg"
8 DISTRO_EXTRA_RDEPENDS += "dpkg"
11 # Map TARGET_ARCH to Debian's ideas about architectures
12 DPKG_ARCH ?= "${TARGET_ARCH}"
13 DPKG_ARCH_x86 ?= "i386"
14 DPKG_ARCH_i486 ?= "i386"
15 DPKG_ARCH_i586 ?= "i386"
16 DPKG_ARCH_i686 ?= "i386"
17 DPKG_ARCH_pentium ?= "i386"
19 python package_deb_fn () {
20 bb.data.setVar('PKGFN', bb.data.getVar('PKG',d), d)
23 addtask package_deb_install
24 python do_package_deb_install () {
25 pkg = bb.data.getVar('PKG', d, 1)
26 pkgfn = bb.data.getVar('PKGFN', d, 1)
27 rootfs = bb.data.getVar('IMAGE_ROOTFS', d, 1)
28 debdir = bb.data.getVar('DEPLOY_DIR_DEB', d, 1)
29 apt_config = bb.data.expand('${STAGING_ETCDIR_NATIVE}/apt/apt.conf', d)
30 stagingbindir = bb.data.getVar('STAGING_BINDIR_NATIVE', d, 1)
31 tmpdir = bb.data.getVar('TMPDIR', d, 1)
33 if None in (pkg,pkgfn,rootfs):
34 raise bb.build.FuncFailed("missing variables (one or more of PKG, PKGFN, IMAGE_ROOTFS)")
36 if not os.exists(rootfs):
41 raise bb.build.FuncFailed(str(sys.exc_value))
43 # update packages file
44 (exitstatus, output) = commands.getstatusoutput('dpkg-scanpackages %s > %s/Packages' % (debdir, debdir))
45 if (exitstatus != 0 ):
46 raise bb.build.FuncFailed(output)
48 f = open(os.path.join(tmpdir, "stamps", "DEB_PACKAGE_INDEX_CLEAN"), "w")
51 # NOTE: this env stuff is racy at best, we need something more capable
52 # than 'commands' for command execution, which includes manipulating the
53 # env of the fork+execve'd processs
56 apt_config_backup = os.getenv('APT_CONFIG')
57 os.putenv('APT_CONFIG', apt_config)
58 path = os.getenv('PATH')
59 os.putenv('PATH', '%s:%s' % (stagingbindir, os.getenv('PATH')))
62 commands.getstatusoutput('apt-get update')
63 commands.getstatusoutput('apt-get install -y %s' % pkgfn)
66 os.putenv('APT_CONFIG', apt_config_backup)
67 os.putenv('PATH', path)
70 python do_package_deb () {
73 workdir = bb.data.getVar('WORKDIR', d, 1)
75 bb.error("WORKDIR not defined, unable to package")
78 outdir = bb.data.getVar('DEPLOY_DIR_DEB', d, 1)
80 bb.error("DEPLOY_DIR_DEB not defined, unable to package")
83 dvar = bb.data.getVar('D', d, 1)
85 bb.error("D not defined, unable to package")
89 packages = bb.data.getVar('PACKAGES', d, 1)
91 bb.debug(1, "PACKAGES not defined, nothing to package")
94 tmpdir = bb.data.getVar('TMPDIR', d, 1)
96 if os.access(os.path.join(tmpdir, "stamps", "DEB_PACKAGE_INDEX_CLEAN"),os.R_OK):
97 os.unlink(os.path.join(tmpdir, "stamps", "DEB_PACKAGE_INDEX_CLEAN"))
100 bb.debug(1, "No packages; nothing to do")
103 for pkg in packages.split():
104 localdata = bb.data.createCopy(d)
105 pkgdest = bb.data.getVar('PKGDEST', d, 1)
106 root = "%s/%s" % (pkgdest, pkg)
108 lf = bb.utils.lockfile(root + ".lock")
110 bb.data.setVar('ROOT', '', localdata)
111 bb.data.setVar('ROOT_%s' % pkg, root, localdata)
112 pkgname = bb.data.getVar('PKG_%s' % pkg, localdata, 1)
115 bb.data.setVar('PKG', pkgname, localdata)
117 overrides = bb.data.getVar('OVERRIDES', localdata)
119 raise bb.build.FuncFailed('OVERRIDES not defined')
120 overrides = bb.data.expand(overrides, localdata)
121 bb.data.setVar('OVERRIDES', overrides + ':' + pkg, localdata)
123 bb.data.update_data(localdata)
124 basedir = os.path.join(os.path.dirname(root))
126 pkgoutdir = os.path.join(outdir, bb.data.getVar('PACKAGE_ARCH', localdata, 1))
127 bb.mkdirhier(pkgoutdir)
130 from glob import glob
131 g = glob('*') + glob('.[!.]*')
133 del g[g.index('DEBIAN')]
134 del g[g.index('./DEBIAN')]
137 if not g and bb.data.getVar('ALLOW_EMPTY', localdata) != "1":
139 note("Not creating empty archive for %s-%s" % (pkg, bb.data.expand('${PV}-${PR}${DISTRO_PR}', localdata, True)))
140 bb.utils.unlockfile(lf)
143 controldir = os.path.join(root, 'DEBIAN')
144 bb.mkdirhier(controldir)
145 os.chmod(controldir, 0755)
147 ctrlfile = file(os.path.join(controldir, 'control'), 'wb')
149 # ctrlfile = codecs.open("someFile", "w", "utf-8")
151 bb.utils.unlockfile(lf)
152 raise bb.build.FuncFailed("unable to open control file for writing.")
155 pe = bb.data.getVar('PE', d, 1)
156 if pe and int(pe) > 0:
157 fields.append(["Version: %s:%s-%s%s\n", ['PE', 'PV', 'PR', 'DISTRO_PR']])
159 fields.append(["Version: %s-%s%s\n", ['PV', 'PR', 'DISTRO_PR']])
160 fields.append(["Description: %s\n", ['DESCRIPTION']])
161 fields.append(["Section: %s\n", ['SECTION']])
162 fields.append(["Priority: %s\n", ['PRIORITY']])
163 fields.append(["Maintainer: %s\n", ['MAINTAINER']])
164 fields.append(["Architecture: %s\n", ['DPKG_ARCH']])
165 fields.append(["OE: %s\n", ['PN']])
166 fields.append(["Homepage: %s\n", ['HOMEPAGE']])
168 # Package, Version, Maintainer, Description - mandatory
169 # Section, Priority, Essential, Architecture, Source, Depends, Pre-Depends, Recommends, Suggests, Conflicts, Replaces, Provides - Optional
175 data = bb.data.getVar(i, d, 1)
178 if i == 'DPKG_ARCH' and bb.data.getVar('PACKAGE_ARCH', d, 1) == 'all':
183 ctrlfile.write("Package: %s\n" % pkgname)
184 # check for required fields
186 for (c, fs) in fields:
187 ctrlfile.write(unicode(c % tuple(pullData(fs, localdata))))
190 (type, value, traceback) = sys.exc_info()
191 bb.utils.unlockfile(lf)
193 raise bb.build.FuncFailed("Missing field for deb generation: %s" % value)
196 bb.build.exec_func("mapping_rename_hook", localdata)
198 rdepends = explode_deps(unicode(bb.data.getVar("RDEPENDS", localdata, 1) or ""))
199 rdepends = [dep for dep in rdepends if not '*' in dep]
200 rrecommends = explode_deps(unicode(bb.data.getVar("RRECOMMENDS", localdata, 1) or ""))
201 rrecommends = [rec for rec in rrecommends if not '*' in rec]
202 rsuggests = (unicode(bb.data.getVar("RSUGGESTS", localdata, 1) or "")).split()
203 rprovides = (unicode(bb.data.getVar("RPROVIDES", localdata, 1) or "")).split()
204 rreplaces = (unicode(bb.data.getVar("RREPLACES", localdata, 1) or "")).split()
205 rconflicts = (unicode(bb.data.getVar("RCONFLICTS", localdata, 1) or "")).split()
207 ctrlfile.write(u"Depends: %s\n" % ", ".join(rdepends))
209 ctrlfile.write(u"Suggests: %s\n" % ", ".join(rsuggests))
211 ctrlfile.write(u"Recommends: %s\n" % ", ".join(rrecommends))
213 ctrlfile.write(u"Provides: %s\n" % ", ".join(rprovides))
215 ctrlfile.write(u"Replaces: %s\n" % ", ".join(rreplaces))
217 ctrlfile.write(u"Conflicts: %s\n" % ", ".join(rconflicts))
220 for script in ["preinst", "postinst", "prerm", "postrm"]:
221 scriptvar = bb.data.getVar('pkg_%s' % script, localdata, 1)
225 scriptfile = file(os.path.join(controldir, script), 'w')
227 bb.utils.unlockfile(lf)
228 raise bb.build.FuncFailed("unable to open %s script file for writing." % script)
229 scriptfile.write("#!/bin/sh\n")
230 scriptfile.write(scriptvar)
232 os.chmod(os.path.join(controldir, script), 0755)
234 conffiles_str = bb.data.getVar("CONFFILES", localdata, 1)
237 conffiles = file(os.path.join(controldir, 'conffiles'), 'w')
239 bb.utils.unlockfile(lf)
240 raise bb.build.FuncFailed("unable to open conffiles for writing.")
241 for f in conffiles_str.split():
242 conffiles.write('%s\n' % f)
246 write_package_md5sums(root, os.path.join(controldir, 'md5sums'),
249 bb.utils.unlockfile(lf)
253 ret = os.system("PATH=\"%s\" fakeroot dpkg-deb -b %s %s" % (bb.data.getVar("PATH", localdata, 1), root, pkgoutdir))
255 bb.utils.unlockfile(lf)
256 raise bb.build.FuncFailed("dpkg-deb execution failed")
258 bb.utils.prunedir(controldir)
259 bb.utils.unlockfile(lf)
263 if bb.data.getVar('PACKAGES', d, True) != '':
264 deps = (bb.data.getVarFlag('do_package_write_deb', 'depends', d) or "").split()
265 deps.append('dpkg-native:do_populate_staging')
266 deps.append('fakeroot-native:do_populate_staging')
267 bb.data.setVarFlag('do_package_write_deb', 'depends', " ".join(deps), d)
270 python do_package_write_deb () {
271 bb.build.exec_func("read_subpackage_metadata", d)
272 bb.build.exec_func("do_package_deb", d)
274 do_package_write_deb[dirs] = "${D}"
275 addtask package_write_deb before do_package_write after do_package