3 def dietlibc_after_parse(d):
6 cfg = oe_filter_out('--(dis|en)able-nls', bb.data.getVar('EXTRA_OECONF', d, 1) or "", d)
7 # Remove shared enable static only
8 cfg += " --disable-nls --disable-shared --enable-static"
9 bb.data.setVar('EXTRA_OECONF', cfg, d)
10 cfg = bb.data.getVar('EXTRA_OEMAKE', d, 1) or ""
11 cfg = oe_filter_out("\'CC=", bb.data.getVar('EXTRA_OEMAKE', d, 1) or "", d)
12 cfgtmp = "\'CC=\"diet ${CCACHE}\""
14 bb.data.setVar('EXTRA_OEMAKE', cfgtmp, d)
17 # dietlibc_after_parse(d)
21 export CC="diet ${CC}"
24 do_compile_prepend() {
28 do_configure_prepend() {