mplayer-common: fix arch and install
[openembedded.git] / recipes / ode / ode_0.9.bb
blob31eed3b884d9e9ce62dce8f76fe52780b3ae553f
1 DESCRIPTION = "ODE is an Open Source Physics Engine."
2 SECTION = "libs"
3 HOMEPAGE = "http://www.ode.org"
4 LICENSE = "LGPL"
5 PR = "r0"
7 SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-src-${PV}.zip \
8 file://install.patch;patch=1"
10 inherit autotools binconfig
12 EXTRA_OECONF = "--disable-demos --enable-soname"
14 do_configure_append() {
15 echo "#define dInfinity DBL_MAX" >>include/ode/config.h
18 do_stage() {
19 oe_runmake install \
20 bindir=${STAGING_BINDIR_CROSS} \
21 libdir=${STAGING_LIBDIR} \
22 includedir=${STAGING_INCDIR} \
23 datadir=${STAGING_DATADIR}
26 do_install() {
27 oe_runmake install \
28 bindir=${D}${bindir} \
29 libdir=${D}${libdir} \
30 includedir=${D}${incdir} \
31 datadir=${D}${datadir}
34 FILES_${PN} = "${libdir}/lib*.so*"