mplayer-common: fix arch and install
[openembedded.git] / recipes / gpe-mini-browser / gpe-mini-browser_0.16.bb
blob35cca41d18d8c637967fe8f3130f147ed61b5aa2
1 require gpe-mini-browser.inc
3 PR = "r1"
5 SRC_URI = "ftp://ftp.handhelds.org/projects/gpe/source/gpe-mini-browser-${PV}.tar.gz"
6 DEPENDS = "osb-nrcit sqlite libgpewidget"
8 S = "${WORKDIR}/gpe-mini-browser-${PV}"
10 inherit autotools
12 do_install() {
13 # install -d ${D}${docdir}/gpe
14 # install -m 0644 ${S}/gpe-mini-browser.html ${D}${docdir}/gpe/
15 install -d ${D}/usr/share/applications
16 install -m 0644 ${S}/gpe-mini-browser.desktop ${D}/usr/share/applications/gpe-mini-browser.desktop
17 install -d ${D}/usr/share/pixmaps
18 install -m 0644 ${S}/gpe-mini-browser.png ${D}/usr/share/pixmaps/gpe-mini-browser.png
19 autotools_do_install
22 pkg_postinst_${PN}-doc () {
23 #!/bin/sh
24 if [ "x$D" != "x" ]; then
25 if [ -e /etc/gpe/gpe-help.conf ]; then
26 echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
27 else
28 echo [Help] >> /etc/gpe/gpe-help.conf
29 echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
31 if [ -x /usr/bin/gpe-helpindex ]; then
32 echo generating help-index
33 gpe-helpindex
34 else
35 echo not generating index for gpe-mini-browser
40 pkg_postrm_${PN}-doc () {
41 #!/bin/sh
42 if [ -e /etc/gpe/gpe-help.conf ]; then
43 sed '/^\<gpe-mini-browser\>/d' /etc/gpe/gpe-help.conf > /tmp/gpe-help.conf
44 mv /tmp/gpe-help.conf /etc/gpe/gpe-help.conf
46 if [ -x /usr/bin/gpe-helpindex ]; then
47 echo generating help-index
48 gpe-helpindex
49 else
50 echo not generating index for gpe-mini-browser