mplayer-common: fix arch and install
[openembedded.git] / recipes / fltk / fltk_1.1.7.bb
blob866db129e80e8ea97f4fc1ae393583b32a0ed66d
1 DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit"
2 HOMEPAGE = "http://www.fltk.org"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "LGPL"
6 DEPENDS = "zlib jpeg libpng libxext libxft"
7 PR = "r2"
9 SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2"
11 S = "${WORKDIR}/fltk-${PV}"
13 inherit autotools binconfig
15 EXTRA_OECONF = "--enable-shared --enable-xdbe --enable-xft --enable-gl --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}"
17 do_configure() {
18 oe_runconf
21 do_stage() {
22 autotools_stage_all
25 do_install () {
26 oe_runmake install prefix="${D}${prefix}" \
27 bindir="${D}${bindir}" \
28 libdir="${D}${libdir}" \
29 includedir="${D}${includedir}" \
30 datadir="${STAGING_DATADIR}"
33 python populate_packages_prepend () {
34 if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
35 bb.data.setVar('PKG_${PN}', 'libfltk${PV}', d)
38 LEAD_SONAME = "libfltk.so"