fso-sounds: add fso-sounds-extras package with all remaining sounds and RSUGGEST it
[openembedded.git] / recipes / miglayout / miglayout_3.0.3.bb
blob7013914d88dbd0c21791c07d5a7cae4b1b73fa62
1 DESCRIPTION = "Flexible layout classes for Swing and SWT"
2 LICENSE = "BSD"
4 AUTHOR = "Mikael Grev"
5 HOMEPAGE = "http://www.migcalendar.com/miglayout"
7 SRC_URI = "http://www.migcalendar.com/${PN}/versions/older/${P}.zip"
9 SRC_URI[md5sum] = "54206117ba825610ace893cebd760ac4"
10 SRC_URI[sha256sum] = "ff7e95e84573ae4ec5a666950a5c07f83d607e7c992c05532729df2a559bc6a2"
12 S = "${WORKDIR}"
14 inherit java-library
16 DEPENDS = "fastjar-native classpath swt3.4-gtk"
17 do_unpack[depends] += "unzip-native:do_populate_sysroot"
19 do_unpackpost() {
20 find -name "*.jar" -exec rm {} \;
22 mkdir sources
23 unzip miglayout-src.zip -d sources
26 addtask unpackpost after do_unpack before do_patch
28 do_compile() {
29 oe_makeclasspath cp -s swt
31 javac \
32 -source 5.0 -sourcepath sources -cp $cp \
33 -d build \
34 `find sources -name "*.java" -and -not -wholename "*demo*"` \
36 fastjar -C build -c -f ${JARFILENAME} .