gnash : add 0.8.8 version
[openembedded.git] / recipes / gnash / gnash_0.8.8.bb
bloba244e1167b0fdabbc315e7b436187c40bdeb2fdd
1 DESCRIPTION = "Gnash is a GNU Flash movie player that supports many SWF v8 features"
2 HOMEPAGE = "http://www.gnu.org/software/gnash"
3 LICENSE = "GPLv3"
4 DEPENDS = "giflib cairo libtool gtk+ agg libsdl-mixer zlib boost jpeg pango curl freetype \
5 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'ffmpeg', d)} speex"
6 DEPENDS += "gst-plugins-base"
8 PR = "r0"
10 SRC_URI = "ftp://ftp.gnu.org/gnu/${PN}/${PV}/${P}.tar.bz2"
12 inherit autotools pkgconfig
14 EXTRA_OECONF = "--enable-gui=gtk \
15 --enable-renderer=agg \
16 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-media=ffmpeg', d)} \
17 --with-plugins-install=system \
18 --enable-plugins \
19 --disable-dependency-tracking \
20 --disable-testsuite \
21 --enable-media=ffmpeg \
22 --with-speex-incl=${STAGING_INCDIR}/speex/ \
23 --with-jpeg-incl=${STAGING_INCDIR} \
24 --with-jpeg-lib=${STAGING_LIBDIR} \
25 --with-top-level=${STAGING_DIR_HOST}/usr \
26 --disable-avm2 \
27 --with-npapi-plugindir=${libdir}/mozilla/plugins \
30 PACKAGES =+ " gnash-browser-plugin libgnashamf libgnashbackend libgnashbase libgnashgeo libgnashgui libgnashplayer libgnashserver "
32 FILES_gnash-browser-plugin= "${libdir}/mozilla/plugins/*"
33 FILES_libgnashamf = "${libdir}/gnash/libgnashamf-${PV}.so"
34 FILES_libgnashbackend = "${libdir}/gnash/libgnashbackend-${PV}.so"
35 FILES_libgnashbase = "${libdir}/gnash/libgnashbase-${PV}.so"
36 FILES_libgnashgeo = "${libdir}/gnash/libgnashgeo-${PV}.so"
37 FILES_libgnashgui = "${libdir}/gnash/libgnashgui-${PV}.so"
38 FILES_libgnashplayer = "${libdir}/gnash/libgnashplayer-${PV}.so"
39 FILES_libgnashserver = "${libdir}/gnash/libgnashserver-${PV}.so"
41 RDEPENDS_${PN}-browser-plugin += "${PN}"
43 acpaths = " -Imacros"
45 # Boost lacks defines for lots of archs
46 TARGET_CC_ARCH_append = " -I${STAGING_INCDIR}/cairo -I${STAGING_INCDIR}/libxml2 -DHAVE_POLL_H ${@[' -D_BIG_ENDIAN', ' -D_LITTLE_ENDIAN'][bb.data.getVar('SITEINFO_ENDIANNESS', d, 1) == 'le']}"
49 do_install_append() {
50 oe_runmake DESTDIR=${D} install-plugin
53 SRC_URI[md5sum] = "ce57f66e222f7eb1adf7f7b4a1274612"
54 SRC_URI[sha256sum] = "dcac4b81f81ecd6cc7c5422d7c731fc5c2a7be7fb18b5570a7e6f8fb5fc6e220"