opencv + samples: update to 2.1.0
[openembedded.git] / recipes / opencv / opencv-samples_svn.bb
blob5acdc4e52f6871099ac90dfbeb7cde19e0e62ee9
1 DESCRIPTION = "Opencv : The Open Computer Vision Library"
2 HOMEPAGE = "http://sourceforge.net/projects/opencvlibrary"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "GPLv2"
7 DEPENDS = "opencv"
9 SRC_URI = "svn://code.ros.org/svn/opencv/trunk;module=opencv;proto=https \
12 SRCREV = "2997"
13 PV = "2.1.0+svnr${SRCPV}"
15 S = "${WORKDIR}/opencv"
17 do_install() {
18 cd samples/c
19 install -d ${D}/${bindir}
20 install -d ${D}/${datadir}/opencv/samples
22 cp * ${D}/${datadir}/opencv/samples || true
24 for i in *.c; do
25 echo "compiling $i"
26 ${CXX} ${CFLAGS} ${LDFLAGS} -ggdb `pkg-config --cflags opencv` -o `basename $i .c` $i `pkg-config --libs opencv` || true
27 install -m 0755 `basename $i .c` ${D}/${bindir} || true
28 rm ${D}/${datadir}/opencv/samples/`basename $i .c` || true
29 done
30 for i in *.cpp; do
31 echo "compiling $i"
32 ${CXX} ${CFLAGS} ${LDFLAGS} -ggdb `pkg-config --cflags opencv` -o `basename $i .cpp` $i `pkg-config --libs opencv` || true
33 install -m 0755 `basename $i .cpp` ${D}/${bindir} || true
34 rm ${D}/${datadir}/opencv/samples/`basename $i .cpp` || true
35 done
38 FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*"
39 FILES_${PN} += "${bindir} ${datadir}/opencv"