opencv + samples: update to 2.1.0
[openembedded.git] / recipes / libsdl / libsdl-mixer_1.2.10.bb
blob44b5a09be0bf0e04fc3a248827f9f35556c7c6c3
1 DESCRIPTION = "Simple DirectMedia Layer mixer library."
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libsdl libmikmod libvorbis"
5 LICENSE = "LGPL"
7 SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
8 S = "${WORKDIR}/SDL_mixer-${PV}"
10 export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
12 inherit autotools_stage
14 EXTRA_OECONF = "--disable-music-mp3"
15 # although we build smpeg... need to find out how
16 # to deal with optional dependencies
18 do_compile() {
19 # Override SDL_LIBS to include a linker rpath so the linker
20 # can find the correct libdl.so when it links playwave to
21 # libSDL_mixer.so.
22 oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
25 SRC_URI[md5sum] = "a357558552436b0b5ea0333b3e2327df"
26 SRC_URI[sha256sum] = "75c4520cde3b1d10ae7846983bde66d114fea9479f6acef352850dae92a1100c"