1 DESCRIPTION
= "Commands for Manipulating POSIX Access Control Lists"
8 SRC_URI
= "http://mirror.its.uidaho.edu/pub/savannah/acl/acl-${PV}.src.tar.gz"
10 inherit autotools lib_package
12 TOPDIR
[unexport
] = "1"
14 EXTRA_OECONF
= " --enable-gettext=yes \
15 ac_cv_path_XGETTEXT=${STAGING_BINDIR_NATIVE}/xgettext \
16 ac_cv_path_MSGFMT=${STAGING_BINDIR_NATIVE}/msgfmt \
17 ac_cv_path_MSGMERGE=${STAGING_BINDIR_NATIVE}/msgmerge "
19 do_configure_append
() {
21 echo
"#define _(str) str" >> $
{S
}/include/config.h
25 export PKG_BIN_DIR
=$
{D
}$
{bindir
}
26 export PKG_SBIN_DIR
=$
{D
}$
{sbindir
}
27 export PKG_LIB_DIR
=$
{D
}$
{libdir
}
28 export PKG_DEVLIB_DIR
=$
{D
}$
{libexecdir
}
29 export PKG_INC_DIR
=$
{D
}$
{includedir
}
30 export PKG_MAN_DIR
=$
{D
}$
{mandir
}
31 export PKG_DOC_DIR
=$
{D
}$
{datadir
}/doc
/acl
32 export PKG_LOCALE_DIR
=$
{D
}$
{datadir
}/locale
33 # ensure the subdir Makefile do
not use the
(wrong
) variable overrides from the
include file
34 export MAKE
="${MAKE} -e"
36 oe_runmake
-e install install
-dev install
-lib
38 sed
-i
-e s
:installed
=yes
:installed
=no
: -e s
:$
{STAGING_LIBDIR
}:$
{libdir
}:g $
{D
}$
{libdir
}/libacl.la
40 # Move .a
and .la into libdir
and remove symlinks pointing
to $
{S
}
41 for file in $
{D
}$
{libexecdir
}/*a
; do
42 rm $
{D
}$
{libdir
}/$
(basename $file
)
43 mv $file $
{D
}$
{libdir
}
45 rm
-rf $
{D
}$
{libexecdir
}
50 SRC_URI
[md5sum
] = "181445894cca986da9ae0099d5ce2d08"
51 SRC_URI
[sha256sum
] = "b9c7f4752e4ef4930a62fa5aa0d7efe1cba2b5a3a2d6ee2b45c0a70c72b7e5d5"