1 DESCRIPTION
= "Open Source multimedia player."
4 HOMEPAGE
= "http://www.mplayerhq.hu/"
5 DEPENDS
= "libvpx live555 libdvdread libtheora virtual/libsdl ffmpeg xsp zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame libxv virtual/libx11 virtual/kernel \
6 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad liba52 lame', d)}"
8 RDEPENDS_$
{PN
} = "mplayer-common"
10 SRC_URI
= "git://repo.or.cz/mplayer/glamo.git;protocol=git;branch=master \
13 SRC_URI_append_armv7a
= " \
14 file://0001-video-out-for-omapfb-support.patch \
17 # This is required
for the collie machine only as all stacks in that
18 # machine seem
to be set
to executable by the toolchain.
If someone
19 # discovers this is more general than please make this more general
20 # ie.
for all armv4 machines.
21 SRC_URI_append_collie
= "file://disable-executable-stack-test.patch"
23 SRCREV
= "81f0b8dacff926d46438faedb1a56da3946a8d2a"
25 PACKAGE_ARCH_collie
= "collie"
26 PACKAGE_ARCH_c7x0
= "c7x0"
27 PACKAGE_ARCH_hx4700
= "hx4700"
29 ARM_INSTRUCTION_SET
= "ARM"
31 RCONFLICTS_$
{PN
} = "mplayer-atty"
32 RREPLACES_$
{PN
} = "mplayer-atty"
34 PV
= "0.0+1.0rc4+gitr${SRCPV}"
36 DEFAULT_PREFERENCE
= "-1"
37 DEFAULT_PREFERENCE_shr
= "2"
43 FILES_$
{PN
} = "${bindir}/mplayer ${libdir} /usr/etc/mplayer/"
44 CONFFILES_$
{PN
} += "/usr/etc/mplayer/input.conf \
45 /usr/etc/mplayer/example.conf \
46 /usr/etc/mplayer/codecs.conf \
49 inherit autotools pkgconfig
51 # We want a kernel header
for armv7a
, but we don't want
to make mplayer machine specific
for that
52 STAGING_KERNEL_DIR
= "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"
57 --target=${SIMPLE_TARGET_SYS} \
65 --disable-xf86keysym \
69 --disable-tv-bsdbt848 \
76 --disable-dvdread-internal \
77 --enable-libdvdcss-internal \
78 --disable-cdparanoia \
155 --disable-win32waveout \
158 --extra-libs=' -lBasicUsageEnvironment -lUsageEnvironment -lgroupsock -lliveMedia -lstdc++' \
161 EXTRA_OECONF_append_armv6
= " --enable-armv6"
162 EXTRA_OECONF_append_armv7a
= " --enable-armv6 --enable-neon"
164 EXTRA_OECONF_append_om
-gta02
= " --enable-glamo"
166 #build with support
for the iwmmxt instruction
and pxa270fb overlay support
(pxa270
and up
)
167 #
not every iwmmxt machine has the lcd connected
to pxafb
, but building the module doesn't hurt
168 MY_ARCH
:= "${PACKAGE_ARCH}"
169 PACKAGE_ARCH
= "${@base_contains('MACHINE_FEATURES', 'iwmmxt', 'iwmmxt', '${MY_ARCH}',d)}"
171 MY_TARGET_CC_ARCH
:= "${TARGET_CC_ARCH}"
172 TARGET_CC_ARCH
= "${@base_contains('MACHINE_FEATURES', 'iwmmxt', '-march=iwmmxt -mtune=iwmmxt', '${MY_TARGET_CC_ARCH}',d)}"
174 EXTRA_OECONF_append
= " ${@base_contains('MACHINE_FEATURES', 'iwmmxt', ' --enable-iwmmxt', '',d)} "
175 EXTRA_OECONF_append
= " ${@base_contains('MACHINE_FEATURES', 'x86', '--enable-runtime-cpudetection', '',d)} "
177 FULL_OPTIMIZATION
= "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O4 -ffast-math"
178 FULL_OPTIMIZATION_armv7a
= "-fexpensive-optimizations -ftree-vectorize -fomit-frame-pointer -O4 -ffast-math"
179 BUILD_OPTIMIZATION
= "${FULL_OPTIMIZATION}"
181 do_configure_prepend_armv7a
() {
182 cp $
{STAGING_KERNEL_DIR
}/arch
/arm
/plat
-omap
/include/mach
/omapfb.h $
{S
}/libvo
/omapfb.h ||
true
183 cp $
{STAGING_KERNEL_DIR
}/include/asm
-arm
/arch
-omap
/omapfb.h $
{S
}/libvo
/omapfb.h ||
true
184 cp $
{STAGING_KERNEL_DIR
}/include/linux
/omapfb.h $
{S
}/libvo
/omapfb.h ||
true
185 sed
-e 's
/__user
//g'
-i $
{S
}/libvo
/omapfb.h ||
true
188 CFLAGS_append
= " -I${S}/libdvdread4 "
191 sed
-i 's|
/usr
/include|$
{STAGING_INCDIR
}|g' $
{S
}/configure
192 sed
-i 's|
/usr
/lib|$
{STAGING_LIBDIR
}|g' $
{S
}/configure
193 sed
-i 's|
/usr
/\S
*include[\w
/]*||g' $
{S
}/configure
194 sed
-i 's|
/usr
/\S
*lib
[\w
/]*||g' $
{S
}/configure
195 sed
-i 's|_install_strip
="-s"|_install_strip
=""|g' $
{S
}/configure
196 sed
-i 's|HOST_CC|BUILD_CC|' $
{S
}/Makefile
198 export SIMPLE_TARGET_SYS
="$(echo ${TARGET_SYS} | sed s:${TARGET_VENDOR}::g)"
199 .
/configure $
{EXTRA_OECONF
}
207 do_install_append
() {
208 install
-d $
{D
}/usr
/etc
/mplayer
209 install $
{S
}/etc
/input.conf $
{D
}/usr
/etc
/mplayer
/
210 install $
{S
}/etc
/example.conf $
{D
}/usr
/etc
/mplayer
/
211 install $
{S
}/etc
/codecs.conf $
{D
}/usr
/etc
/mplayer
/