u-boot: Move the config target into do_configure
[openembedded.git] / recipes / u-boot / u-boot-utils_1.2.0.bb
blob013de890b04a15d2692b133235ed0d805056f233
1 DESCRIPTION = "U-boot bootloader OS env. access tools"
2 SECTION = "bootloaders"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 DEPENDS = "mtd-utils"
6 PR = "r9"
8 SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
9 file://fw_env.c.patch \
10 file://tools-Makefile.patch \
11 file://env-Makefile.patch \
12 file://fw_env.config"
14 S = "${WORKDIR}/u-boot-${PV}"
16 EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
17 TARGET_LDFLAGS = ""
18 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-${PV}"
20 do_configure() {
21 oe_runmake Sandpoint8240_config
24 do_compile () {
25 oe_runmake tools
28 do_install () {
29 install -d ${D}/sbin
30 install -d ${D}${sysconfdir}
31 install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
32 install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_printenv
33 install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_setenv
37 SRC_URI[md5sum] = "17aeee76ca4c07887bbfea8a52d40884"
38 SRC_URI[sha256sum] = "62192ddf019c5d24f6538b33c9e69b6e5792bf5b0f464c0149061e2f0871108b"