u-boot: Move the config target into do_configure
[openembedded.git] / recipes / u-boot / u-boot-utils-native_1.2.0.bb
blob771f31b46f826e4a4bf4505dd0a286ae9b73f2fe
1 DESCRIPTION = "U-boot bootloader mkimage utility"
2 SECTION = "bootloaders"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 ALLOW_EMPTY = "1"
6 PR = "r1"
8 SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
10 S = "${WORKDIR}/u-boot-${PV}"
12 inherit native
14 do_configure() {
15 oe_runmake Sandpoint8240_config
18 do_compile () {
19 oe_runmake tools
22 # install mkimage for the kernel makefile
23 do_stage() {
24 install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/
28 SRC_URI[md5sum] = "17aeee76ca4c07887bbfea8a52d40884"
29 SRC_URI[sha256sum] = "62192ddf019c5d24f6538b33c9e69b6e5792bf5b0f464c0149061e2f0871108b"