angstrom-eglibc: fix eabi target os assignment
[openembedded.git] / recipes / gnome / gnome-vfs_2.24.1.bb
blob511aabe5a7a3d5d9f2f3e5db42981dadd4d0a5fa
1 LICENSE = "GPL"
2 DEPENDS = "libxml2 gconf gnutls avahi dbus dbus-glib bzip2 gnome-mime-data zlib gtk-doc-native"
3 RRECOMMENDS = "gnome-vfs-plugin-file shared-mime-info"
4 # Some legacy packages will require gnome-mime-data to be installed, but use of
5 # it is deprecated.
6 PR = "r1"
8 inherit gnome
10 SRC_URI += "file://gconftool-lossage.patch;patch=1;pnum=1 \
11 file://gnome-vfs-no-kerberos.patch;patch=1;pnum=0"
13 # This is to provide compatibility with the gnome-vfs DBus fork
14 PROVIDES = "gnome-vfs-plugin-dbus"
15 RREPLACES = "gnome-vfs-dbus"
17 EXTRA_OECONF = " \
18 --disable-openssl \
19 --enable-gnutls \
20 --enable-avahi \
21 --with-samba-includes=${STAGING_INCDIR} \
24 do_configure_prepend() {
25 sed -i -e 's: doc ::g' Makefile.am
28 do_stage () {
29 autotools_stage_all
32 PACKAGES_DYNAMIC = "gnome-vfs-plugin-*"
34 python populate_packages_prepend () {
35 print bb.data.getVar('FILES_gnome-vfs', d, 1)
37 plugindir = bb.data.expand('${libdir}/gnome-vfs-2.0/modules/', d)
38 do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s')
41 FILES_${PN} += "${libdir}/vfs ${datadir}/dbus-1/services"
42 FILES_${PN}-dbg += "${libdir}/gnome-vfs-2.0/modules/.debug"
43 FILES_${PN}-dev += "${libdir}/gnome-vfs-2.0/include \
44 ${libdir}/gnome-vfs-2.0/modules/*.a \
45 ${libdir}/gnome-vfs-2.0/modules/*.la \
47 FILES_${PN}-doc += "${datadir}/gtk-doc"