guile-native: make sure we don't have -Werror as compiler flag
[openembedded.git] / recipes / udev / udev-static-devices.bb
blobf0aab5a6a2644577bc5dd62d1fd6b3e847093518
1 DESCRIPTION = "Provide per-machine static nodes of /dev"
2 RDEPENDS = "udev"
4 PR = "r0"
6 SRC_URI = "file://udev_static_devices_tarball"
8 FILES_${PN} += "${base_libdir}/udev/*"
10 do_install () {
11 install -d ${D}${base_libdir}/udev/devices
12 if [ -s ${WORKDIR}/udev_static_devices_tarball ]; then
13 install -m 0644 ${WORKDIR}/udev_static_devices_tarball ${D}${base_libdir}/udev/devices.tar.gz
17 pkg_postinst () {
18 ROOT="$D"
19 if [ -f "$ROOT/lib/udev/devices.tar.gz" ]; then
20 tar -C "$ROOT/lib/udev" -zxf "$ROOT/lib/udev/devices.tar.gz" || exit $?