guile-native: make sure we don't have -Werror as compiler flag
[openembedded.git] / recipes / ica / ica-bin_8.0.bb
blobede48ffe3bf6b8f9310d8345cc6f1663873970f4
1 # ica-bin OE build file
2 # Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
5 DEPENDS = "virtual/libx11 libxaw rpm2cpio-native"
7 HOMEPAGE="www.citrix.com/download/"
9 SRC_URI="file://${DL_DIR}/ICAClient-8.0-1.i386.rpm"
11 S="${WORKDIR}"
12 PACKAGES= "${PN}"
13 FILES_${PN} = "/"
15 python ica_do_fetch() {
16 import os
17 def dowarn(str,d):
18 out = bb.data.expand(str, d)
19 bb.note(out)
21 file = bb.data.getVar('A', d)
22 basen = os.path.basename(file)
24 if not os.path.exists(file):
25 dowarn('You need to perform the following steps to build this package:',d)
26 dowarn('Sign up at ${HOMEPAGE}',d)
27 dowarn('- Download %s and place it in ${DL_DIR}' % basen,d)
28 dowarn('- make this package again',d)
29 raise bb.build.FuncFailed('Package not downloaded')
32 python do_fetch() {
33 bb.build.exec_func('ica_do_fetch', d)
34 bb.build.exec_func('base_do_fetch', d)
37 do_unpack() {
38 rpm2cpio.pl ${A} | cpio -i --make-directories
41 do_compile() {
44 DDIR="${D}/usr/lib/ICAClient"
46 do_install () {
47 for file in `find usr/lib/ICAClient/ -type d`; do
48 install -d ${D}/$file
49 done
51 for file in `find usr/lib/ICAClient/ -type f`; do
52 install $file ${D}/$file
53 done