guile-native: make sure we don't have -Werror as compiler flag
[openembedded.git] / recipes / giac / giac_0.5.0.bb
blob36df3c22b7f41bdefa5da10446d0e689bbf1a891
1 SECTION = "console/utils"
2 DESCRIPTION = "A free computer algebra system"
3 HOMEPAGE = "http://www-fourier.ujf-grenoble.fr/~parisse/giac.html"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "fltk gmp mpfr gsl"
7 # ntl pari"
9 SRC_URI = "ftp://ftp-fourier.ujf-grenoble.fr/xcas/giac-${PV}.tar.gz"
11 inherit autotools
13 PACKAGES += " lib${PN}"
14 FILES_${PN} = "${bindir} \
15 ${datadir}/${PN}"
16 FILES_lib${PN} = "${libdir}"
18 # breaks the build...
19 #EXTRA_OECONF = "--enable-debug=no"
21 # skip autoreconf for now (fails due to improper local macros)
22 do_configure() {
23 oe_runconf
26 do_install () {
27 oe_runmake prefix="${D}${prefix}" \
28 bindir="${D}${bindir}" \
29 libdir="${D}${libdir}" \
30 includedir="${D}${includedir}" \
31 install
33 # put the docs where they belong
34 # might need further investigation in case giac needs
35 # them in the original place
36 install -d ${D}${docdir}
37 mv ${D}${datadir}/${PN}/doc ${D}${docdir}/${PN}