linux-nokia900-meego: minimize defconfig with savedefconfig
[openembedded.git] / recipes / lcdproc / lcdproc_0.4.5.bb
blobfc63e2a5e450b474a945223735309b5fa88672fd
1 DESCRIPTION = "LCDproc is a client/Server suite to drive all kinds of LCD (-like) devices. The client \
2 shipped with this package can be used to acquire various kinds of system stats."
3 HOMEPAGE = "http://lcdproc.org"
4 LICENSE ="GPL"
5 PRIORITY = "optional"
6 SECTION = "utils"
7 PR = "r1"
9 DEPENDS = "${@((bb.data.getVar('LCDPROC_DRIVERS',d) or 'curses,text').find('curses') != -1) and 'ncurses' or ''}"
11 SRC_URI = "${SOURCEFORGE_MIRROR}/lcdproc/lcdproc-${PV}.tar.gz"
13 inherit autotools
15 EXTRA_OECONF = "${@'--enable-drivers=' + (bb.data.getVar('LCDPROC_DRIVERS',d) or 'curses,text')}"
17 do_install () {
18 # binaries
19 install -D -m 0755 server/LCDd ${D}${sbindir}/LCDd
20 install -D -m 0755 clients/lcdproc/lcdproc ${D}${bindir}/lcdproc
22 # init scripts
23 install -D -m 0755 scripts/init-LCDd.debian ${D}${sysconfdir}/init.d/lcdd
24 # prevent lcdproc from starting if no SCREENS are set.
25 # will be fixed in next upstream release
26 cat scripts/init-lcdproc.debian | sed -e 's/C X//' | sed -e 's/case/[ -n $SCREENS ] || exit 0\n\ncase/' > ${D}${sysconfdir}/init.d/lcdproc
27 chmod 0755 ${D}${sysconfdir}/init.d/lcdproc
29 # configuration files
30 install -D -m 0644 LCDd.conf ${D}${sysconfdir}/LCDd.conf
31 # don't start lcdproc by default
32 # will be fixed in next upstream release
33 cat scripts/lcdproc.conf | sed -e 's/C X//' > ${D}${sysconfdir}/lcdproc.conf
34 chmod 0644 ${D}${sysconfdir}/lcdproc.conf
37 pkg_postinst () {
38 if test -n "${D}"; then
39 D="-r $D"
41 update-rc.d $D lcdd defaults 70 21
42 update-rc.d $D lcdproc defaults 71 20
45 pkg_prerm () {
46 if test -n "${D}"; then
47 D="-r $D"
49 update-rc.d $D lcdproc remove
50 update-rc.d $D lcdd remove
53 SRC_URI[md5sum] = "c1e74364963054b26b2a77a37bd2bf36"
54 SRC_URI[sha256sum] = "a2163b474d75dc87891c6a81ce9e89f0c9ceab7cbef14b50f066bf3508eec977"