linux-nokia900-meego: minimize defconfig with savedefconfig
[openembedded.git] / recipes / ezx / moto-boot-usb-native_git.bb
blob5147d722daaab683d39569e96efd10672091d6e5
1 DESCRIPTION = "Boot a Motorola EZX device with a user supplied kernel"
2 DEPENDS = "virtual/libusb0-native virtual/kernel"
3 SECTION = "devel"
4 AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
5 LICENSE = "GPL"
6 SRCREV = "aeef3f44a1358fee15da193876e8ebc716dcd550"
7 PV = "0.3.0+gitr${SRCPV}"
8 PR = "r0"
9 PE = "1"
11 SRC_URI = "git://git.openezx.org/moto-boot-usb.git;protocol=git;branch=master"
12 S = "${WORKDIR}/git"
14 EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
16 inherit autotools native
18 do_deploy() {
19 install -d ${DEPLOY_DIR_TOOLS}
20 install -m 0755 src/moto-boot-usb ${DEPLOY_DIR_TOOLS}/moto-boot-usb-${PV}
23 do_install() {
27 addtask deploy before do_build after do_compile