evas-native: add libxext-native as dependency
[openembedded.git] / recipes / gnome / gnome-keyring_2.26.0.bb
blobabec0f1b38f66916576f599c7b70650afa78f2df
1 LICENSE = "GPL"
2 SECTION = "x11/gnome"
4 inherit autotools gnome pkgconfig
6 DEPENDS = "gconf-dbus gtk+ libtasn1 libtasn1-native libgcrypt"
7 DEPENDS = " libpam gconf gtk+ libtasn1 libtasn1-native libgcrypt"
9 EXTRA_OECONF = "--disable-gtk-doc"
11 SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service"
13 do_configure_prepend() {
14 cp ${WORKDIR}/tasn.m4 acinclude.m4
17 do_install_append () {
18 install -d ${D}${datadir}/dbus-1/services
19 install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
22 FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr"
23 PACKAGES =+ "gnome-keyring-pam-plugin"
24 FILES_gnome-keyring-pam-plugin = "${libdir}/security/*.so"
25 FILES_${PN}-dbg += "${libdir}/gnome-keyring/*/.debug ${libdir}/security/.debug"
27 do_stage() {
28 autotools_stage_all