opkg-utils: Fix typo and drop duplicate S entry
[openembedded.git] / recipes / tasks / task-shr-minimal.bb
blob4e7dbae0d51bd27425b5b27dc96a711d82d74d2b
1 DESCRIPTION = "SHR Lite Image Feed"
2 PR = "r33"
3 PV = "2.0"
4 LICENSE = "GPL"
6 inherit task
8 PACKAGE_ARCH = "${MACHINE_ARCH}"
10 def get_rdepends(bb, d):
11 enabled = bb.data.getVar("ENABLE_BINARY_LOCALE_GENERATION", d, 1)
13 # If locale is disabled, bail out
14 if not enabled or not int(enabled):
15 return ""
17 locales = bb.data.getVar("GLIBC_GENERATE_LOCALES", d, 1)
18 if not locales or locales == "all":
19 locales = bb.data.getVar("IMAGE_LINGUAS", d, 1);
21 libc = bb.data.getVar('LIBC', d, 1)
22 import re
24 rdepends = ""
25 if not locales or locales == "all":
26 # if locales aren't specified, or user has written "all"
27 import os
28 ipkdir = bb.data.getVar('DEPLOY_DIR_IPK', d, 1)
30 regexp1 = re.compile(libc+"-binary-localedata-.*") # search pattern
31 regexp2 = re.compile("_.*") # we want to remove all version info and file extension
33 for root, subFolders, files in os.walk(ipkdir):
34 for file in files:
35 if regexp1.search(file):
36 file = regexp2.sub("", file)
37 rdepends = "%s %s" % (rdepends, file)
39 else:
40 # if locales are specified
41 regexp1 = re.compile("\\..*") # We want to turn en_US.UTF-8 into en_US
42 regexp2 = re.compile("_") # We want to turn en_US into en-US
45 for locale in locales.split(" "):
46 locale = regexp1.sub("", locale)
47 locale = regexp2.sub("-", locale)
48 locale = str.lower(locale)
49 rdepends = "%s %s-binary-localedata-%s" % (rdepends, libc, locale)
50 return rdepends
55 PACKAGES += "\
56 ${PN}-base \
57 ${PN}-cli \
58 ${PN}-fso \
59 ${PN}-audio \
60 ${PN}-x \
61 ${PN}-apps \
62 ${PN}-gtk \
67 RDEPENDS_${PN}-base = "\
68 ${MACHINE_TASK_PROVIDER} \
69 task-base \
70 glibc-utils \
71 glibc-charmap-utf-8 \
72 netbase \
73 sysfsutils \
74 modutils-initscripts \
75 module-init-tools-depmod \
76 fbset \
77 fbset-modes \
78 cron \
79 logrotate\
80 util-linux-ng-fdisk \
81 shr-splash \
84 RDEPENDS_${PN}-cli = "\
85 nano \
86 mtd-utils \
89 RDEPENDS_${PN}-fso = "\
90 fsoraw \
91 fso-gpsd \
92 opimd-utils-cli \
93 python-codecs \
94 python-gst \
98 #FIXME: libcanberra-alsa should be pulled in by fsodeviced but isn't
99 RDEPENDS_${PN}-audio = "\
100 alsa-utils-alsactl \
101 alsa-utils-alsamixer \
102 alsa-utils-aplay \
103 alsa-utils-amixer \
104 libcanberra-alsa \
107 RDEPENDS_${PN}-x = "\
108 task-x11-illume \
109 task-fonts-truetype-core \
110 e-wm-menu-shr \
111 shr-wizard \
112 shr-theme-gry \
113 xcursor-transparent-theme \
114 xinput-calibrator \
115 # Needed for proper input support in efl based apps
116 libx11-locale \
117 # All localedata based on IMAGE_LINGUAS
118 ${@get_rdepends(bb, d)} \
121 RDEPENDS_${PN}-apps = "\
122 task-fso2-compliance \
123 phoneui-apps-messages \
124 phoneui-apps-contacts \
125 phoneui-apps-dialer \
126 phoneui-apps-quick-settings \
127 phonefsod \
128 phoneuid \
129 libphone-ui \
130 libphone-ui-shr \
131 ffalarms \
132 shr-settings \
133 shr-theme \
134 calc \
138 RDEPENDS_${PN}-gtk = "\
139 shr-theme-gtk-e17lookalike \
140 vala-terminal \
141 pyphonelog \
142 matchbox-keyboard-im \