libogg: update to version 1.1.4
[openembedded.git] / recipes / libogg / libtheora_1.0.bb
blob431ed395252e684e681a1147dd52dca9f0464dec
2 DEPENDS = "libogg libvorbis"
4 PR = "r3"
6 SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-${PV}.tar.bz2 \
7 file://libtheora-1.0-no-docs.patch;patch=1"
9 inherit autotools lib_package
11 EXTRA_OECONF = "--disable-examples"
13 LEAD_SONAME = "libtheora.so.0"
15 do_configure_append() {
16 find ${S} -name Makefile | xargs sed -i -e s:'-I/usr/include':-I${STAGING_INCDIR}:g
19 AUTOTOOLS_STAGE_PKGCONFIG = "1"
21 do_stage() {
22 autotools_stage_all