tsmd: install also a little helper script to control the touchscreen daemon
[openembedded.git] / recipes / systemd / systemd_git.bb
blob5f98e54b1ba13ae964163306346aadb00b18da39
1 DESCRIPTION = "Systemd a init replacement"
2 HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd"
3 LICENSE = "GPL"
4 DEPENDS = "readline udev dbus libcap2 libcgroup gtk+"
5 PRIORITY = "optional"
6 SECTION = "base/shell"
8 PV = "0.0"
9 PR_append = "+${SRCPV}"
11 inherit autotools vala
13 TAG = "1ebdf2d8793181f31b766b8342391aa1978f9917"
15 SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git;tag=${TAG} \
16 file://execute.patch \
17 file://systemadm.patch \
18 file://disable_xml_generation.patch \
19 file://replace_accpet4.patch \
20 file://getty-serial@.service \
23 S = "${WORKDIR}/git"
25 EXTRA_OECONF = " --with-distro=debian \
26 --with-rootdir=${base_prefix} \
29 PACKAGES = "${PN} ${PN}-gui ${PN}-dbg ${PN}-doc"
31 FILES_${PN}-gui = "${bindir}/systemadm"
33 FILES_${PN} = " ${base_bindir}/* \
34 ${datadir}/dbus-1/services \
35 ${datadir}/dbus-1/system-services \
36 ${datadir}/${PN} \
37 ${sysconfdir} \
38 ${base_libdir}/systemd/* \
39 ${base_libdir}/systemd/system/* \
40 ${base_libdir}/udev/rules.d \
41 /cgroup \
42 ${bindir}/systemd-install \
45 FILES_${PN}-dbg += " /lib/systemd/.debug "
47 def get_baudrate(bb, d):
48 return bb.data.getVar('SERIAL_CONSOLE', d, 1).split()[0]
51 def get_console(bb, d):
52 return bb.data.getVar('SERIAL_CONSOLE', d, 1).split()[1]
55 do_install_append(){
56 if [ ! ${@get_baudrate(bb, d)} = "" ]; then
57 sed -i -e s/\@BAUDRATE\@/${@get_baudrate(bb, d)}/g ${WORKDIR}/getty-serial@.service
58 install ${WORKDIR}/getty-serial@.service ${D}${base_libdir}/systemd/system/
59 ln -sf ${base_libdir}/systemd/system/getty-serial@.service \
60 ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@${@get_console(bb, d)}.service