tsmd: install also a little helper script to control the touchscreen daemon
[openembedded.git] / recipes / netkit-tftp / netkit-tftpd_0.17.bb
blob44f29a1b6b892f3e738f458c9f6592cb399a75f1
1 SECTION = "console/network"
2 DESCRIPTION = "netkit-tftpd includes a tftp server."
3 DEPENDS = "netkit-base"
4 RDEPENDS_${PN} = "netkit-base"
5 LICENSE = "BSD"
6 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/netkit-tftp-${PV}"
8 SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-tftp-${PV}.tar.gz \
9 file://mconfig.patch \
10 file://tftpd_add_debug.patch \
11 file://pack_tftphdr.patch"
13 S = "${WORKDIR}/netkit-tftp-${PV}"
15 PR = "r8"
17 EXTRA_OEMAKE = ""
18 do_compile () {
19 oe_runmake 'CC=${CC}' 'LD=${LD}' all
22 do_install () {
23 install -d ${D}${sbindir}
24 install -m 0755 tftpd/tftpd ${D}${sbindir}/tftpd
27 pkg_postinst () {
28 #only run on the device
29 if [ -n "$D" ]; then exit 1; fi
31 #install inetd.conf line to run tftpd
32 echo "tftp dgram udp wait root ${sbindir}/tftpd tftpd" >> /etc/inetd.conf
34 #force inetd to reload settings
35 kill -SIGHUP `cat /var/run/inetd.pid`
38 SRC_URI[md5sum] = "b7262c798e2ff50e29c2ff50dfd8d6a8"
39 SRC_URI[sha256sum] = "3a43c0010d4e61f412563fd83769d4667d8b8e82903526d21cb9205fe55ad14d"