tsmd: install also a little helper script to control the touchscreen daemon
[openembedded.git] / recipes / libnet / libnet_1.1.2.1.bb
blobb09f56eda675340699549d4755279faf0fa0ba71
1 DESCRIPTION = "A packet dissection and creation library"
2 HOMEPAGE = "http://www.packetfactory.net/libnet/"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "BSD"
6 DEPENDS = "libpcap"
7 # There are major API changes beween libnet v1.0 and libnet v1.1
8 PROVIDES = "libnet-1.1"
9 PR = "r4"
11 SRC_URI = "${DEBIAN_MIRROR}/main/libn/libnet/libnet_${PV}.orig.tar.gz \
12 file://support-uclibc.patch \
13 file://fix-endianess-test.patch \
14 file://new-autotools.patch"
16 S = "${WORKDIR}/libnet"
18 inherit autotools binconfig
20 do_configure_prepend() {
21 rm -f aclocal.m4 Makefile.am ltmain.sh
24 do_install_append () {
25 oe_runmake -C src 'DESTDIR=${D}${libdir}/' 'libdir=' install-libLIBRARIES
26 oe_runmake -C include 'DESTDIR=${D}${includedir}/' 'includedir=' install-includeHEADERS
27 oe_runmake -C include/libnet 'DESTDIR=${D}${includedir}/' 'includedir=' install-libnetincludeHEADERS
28 install -d ${D}${datadir}/man/man3/
29 install -d ${D}${bindir}
30 install -m 0644 ${S}/doc/man/man3/*.3 ${D}${datadir}/man/man3/
31 install -m 0755 ${S}/libnet-config ${D}${bindir}
34 #static build
35 FILES_${PN} = ""
36 FILES_${PN}-dev += "${bindir}/libnet-config"
38 CPPFLAGS_prepend = "-I${S}/libnet/include "
40 SRC_URI[md5sum] = "be845c41170d72c7db524f3411b50256"
41 SRC_URI[sha256sum] = "ab01882a3d0556176018c09342cd0731f7cbc8e687795009894c3326942c76ff"