tsmd: install also a little helper script to control the touchscreen daemon
[openembedded.git] / recipes / frotz / frotz_2.42.bb
blobc74b1323e0e754452f5a22018bf3adc772d7cdef
1 LICENSE = "GPL"
2 DESCRIPTION = "Frotz is an interpreter for Infocom games and other Z-machine games."
3 HOMEPAGE = "http://frotz.sourceforge.net/"
4 SECTION = "console/games"
5 PR = "r1"
7 DEPENDS = "ncurses"
9 SRC_URI = "http://downloads.sourceforge.net/project/frotz/frotz/2.42/frotz-${PV}.tar.gz \
10 file://Makefile.patch "
12 do_configure() {
13 patch -N ${s}/ux_init.c < remove_root_restriction.patch || :
14 rm -f ${SourceTree}/frotz.conf
17 EXTRA_OEMAKE = "CC='${CC}' INCL='${CFLAGS}' LIB='${LDFLAGS}' PREFIX=${prefix} CONFIG_DIR=${sysconfdir}"
19 do_compile() {
20 oe_runmake frotz
21 sed 's/^[a-z]/#&/' frotz.conf-big > frotz.conf;
24 do_install() {
25 oe_runmake PREFIX=${D}${prefix} MAN_PREFIX=${D}${mandir} install
28 SRC_URI[md5sum] = "a1cf81b39f749ea96e4585238ffc1b3f"
29 SRC_URI[sha256sum] = "cbdd2b2911aaf57a3efa6e12d4b45036b80efbb3ede30e88118fc528d90a4768"