tsmd: install also a little helper script to control the touchscreen daemon
[openembedded.git] / recipes / devmem2 / devmem2.bb
blob2d1e67b6278cb8374f76dbb734a403b0397856c7
1 DESCRIPTION = "Simple program to read/write from/to any location in memory."
2 LICENSE = "GPLv2"
3 PR = "r7"
5 SRC_URI = "http://www.lartmaker.nl/lartware/port/devmem2.c \
6 file://devmem2-fixups-2.patch;apply=yes;striplevel=0"
7 S = "${WORKDIR}"
9 CFLAGS += "-DFORCE_STRICT_ALIGNMENT"
11 do_compile() {
12 ${CC} -o devmem2 devmem2.c ${CFLAGS} ${LDFLAGS}
15 do_install() {
16 install -d ${D}${bindir}
17 install devmem2 ${D}${bindir}
20 SRC_URI[md5sum] = "be12c0132a1ae118cbf5e79d98427c1d"
21 SRC_URI[sha256sum] = "ec382c90af3ef2f49695ff14a4d6521e58ac482c4e29d6c9ebca8768f699c191"