tsmd: install also a little helper script to control the touchscreen daemon
[openembedded.git] / recipes / bonjour / bonjour_107.6.bb
blobe21c92f1866fdb05fcf6a8d6d6e11eda6f29d7a5
1 DESCRIPTION = "Bonjour is a networking technology that lets you create an instant network of computers and devices without any configuration."
2 SECTION = "network"
3 LICENSE = "Apache-2.0"
5 RDEPENDS_bonjour = "update-rc.d"
7 PR = "r3"
9 SRC_URI = "http://www.opensource.apple.com/darwinsource/tarballs/other/mDNSResponder-${PV}.tar.gz \
10 file://bonjour.conf \
11 file://bonjour.init \
14 S = "${WORKDIR}/mDNSResponder-${PV}"
16 inherit update-rc.d
18 INITSCRIPT_NAME = "bonjour"
19 INITSCRIPT_PARAMS = "defaults 50"
21 EXTRA_OEMAKE = 'CC="${CC} ${LDFLAGS}" os=linux -C ${S}/mDNSPosix SAResponder'
22 PARALLEL_MAKE = ""
24 do_install() {
26 install -d ${D}${sbindir}
27 install -m 0755 mDNSPosix/build/prod/mDNSResponderPosix ${D}${sbindir}/mdnsd
29 install -d ${D}${sysconfdir}/init.d
30 install -m 0755 ${WORKDIR}/bonjour.init ${D}${sysconfdir}/init.d/bonjour
31 install -m 0640 ${WORKDIR}/bonjour.conf ${D}${sysconfdir}/
35 SRC_URI[md5sum] = "aa4e0e5c57f94489463ea6576591ce9d"
36 SRC_URI[sha256sum] = "43d427d3d5c78aef57a49898def469cc4cae28190462205368be1f3a0fcc0165"