2 # Sanity check the users setup for common misconfigurations
7 def raise_sanity_error(msg):
9 bb.fatal(""" Openembedded's config sanity checker detected a potential misconfiguration.
10 Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
11 Following is the list of potential problems / advisories:
15 def check_conf_exists(fn, data):
17 fn = bb.data.expand(fn, data)
18 vbbpath = bb.data.getVar("BBPATH", data)
20 bbpath += vbbpath.split(":")
22 currname = os.path.join(bb.data.expand(p, data), fn)
23 if os.access(currname, os.R_OK):
28 from bb import note, error, data, __version__
31 from distutils.version import LooseVersion
34 bb.msg.warn(None, "sanity.bbclass can't compare versions without python-distutils")
38 # Check the bitbake version meets minimum requirements
39 minversion = data.getVar('BB_MIN_VERSION', e.data , True)
41 # Hack: BB_MIN_VERSION hasn't been parsed yet so return
42 # and wait for the next call
46 raise_sanity_error("Do not use Bitbake as root.")
50 if (LooseVersion(__version__) < LooseVersion(minversion)):
51 messages = messages + 'Bitbake version %s is required and version %s was found\n' % (minversion, __version__)
53 # Check TARGET_ARCH is set
54 if data.getVar('TARGET_ARCH', e.data, True) == 'INVALID':
55 messages = messages + 'Please set TARGET_ARCH directly, or choose a MACHINE or DISTRO that does so.\n'
57 # Check TARGET_OS is set
58 if data.getVar('TARGET_OS', e.data, True) == 'INVALID':
59 messages = messages + 'Please set TARGET_OS directly, or choose a MACHINE or DISTRO that does so.\n'
61 assume_provided = data.getVar('ASSUME_PROVIDED', e.data , True).split()
62 # Check user doesn't have ASSUME_PROVIDED = instead of += in local.conf
63 if "diffstat-native" not in assume_provided:
64 messages = messages + 'Please use ASSUME_PROVIDED +=, not ASSUME_PROVIDED = in your local.conf\n'
66 # Check that the MACHINE is valid, if it is set
67 if data.getVar('MACHINE', e.data, True):
68 if not check_conf_exists("conf/machine/${MACHINE}.conf", e.data):
69 messages = messages + 'Please set a valid MACHINE in your local.conf\n'
71 # Check that the DISTRO is valid
72 # need to take into account DISTRO renaming DISTRO
73 if not ( check_conf_exists("conf/distro/${DISTRO}.conf", e.data) or check_conf_exists("conf/distro/include/${DISTRO}.inc", e.data) ):
74 messages = messages + "DISTRO '%s' not found. Please set a valid DISTRO in your local.conf\n" % data.getVar("DISTRO", e.data, True )
78 if not check_app_exists("${MAKE}", e.data):
79 missing = missing + "GNU make,"
81 if not check_app_exists('${BUILD_PREFIX}gcc', e.data):
82 missing = missing + "C Compiler (${BUILD_PREFIX}gcc),"
84 if not check_app_exists('${BUILD_PREFIX}g++', e.data):
85 missing = missing + "C++ Compiler (${BUILD_PREFIX}g++),"
87 required_utilities = "patch diffstat texi2html makeinfo cvs svn bzip2 tar gzip gawk md5sum chrpath"
89 # If we'll be running qemu, perform some sanity checks
90 if data.getVar('ENABLE_BINARY_LOCALE_GENERATION', e.data, True):
91 if "qemu-native" in assume_provided:
92 required_utilities += " %s" % (qemu_target_binary(e.data))
94 for util in required_utilities.split():
95 if not check_app_exists( util, e.data ):
96 missing = missing + "%s," % util
99 missing = missing.rstrip(',')
100 messages = messages + "Please install following missing utilities: %s\n" % missing
103 if os.path.basename(os.readlink('/bin/sh')) == 'dash':
104 messages = messages + "Using dash as /bin/sh causes various subtle build problems, please use bash instead.\n"
108 omask = os.umask(022)
110 messages = messages + "Please use a umask which allows a+rx and u+rwx\n"
113 oes_bb_conf = data.getVar( 'OES_BITBAKE_CONF', e.data, True )
115 messages = messages + 'You do not include OpenEmbeddeds version of conf/bitbake.conf. This means your environment is misconfigured, in particular check BBPATH.\n'
118 # Check that TMPDIR hasn't changed location since the last time we were run
120 tmpdir = data.getVar('TMPDIR', e.data, True)
121 checkfile = os.path.join(tmpdir, "saved_tmpdir")
122 if os.path.exists(checkfile):
123 f = file(checkfile, "r")
124 oldpath = f.read().strip()
125 if (oldpath != tmpdir):
126 messages = messages + "Error, TMPDIR has changed location. You need to either move it back to %s or rebuild\n" % oldpath
130 f = file(checkfile, "w")
135 # Check the 'ABI' of TMPDIR
137 current_abi = data.getVar('OELAYOUT_ABI', e.data, True)
138 abifile = data.getVar('SANITY_ABIFILE', e.data, True)
139 if os.path.exists(abifile):
140 f = file(abifile, "r")
141 abi = f.read().strip()
142 if not abi.isdigit():
143 f = file(abifile, "w")
145 elif abi == "3" and current_abi == "4":
147 bb.note("Converting staging from layout version 2 to layout version 3")
148 os.system(bb.data.expand("mv ${TMPDIR}/staging ${TMPDIR}/sysroots", e.data))
149 os.system(bb.data.expand("ln -s sysroots ${TMPDIR}/staging", e.data))
150 os.system(bb.data.expand("cd ${TMPDIR}/stamps; for i in */*do_populate_staging; do new=`echo $i | sed -e 's/do_populate_staging/do_populate_sysroot/'`; mv $i $new; done", e.data))
151 f = file(abifile, "w")
153 elif abi == "5" and current_abi != "5":
154 messages = messages + "Staging layout has changed. The cross directory has been deprecated and cross packages are now built under the native sysroot.\nThis requires a rebuild.\n"
155 elif (abi != current_abi):
156 # Code to convert from one ABI to another could go here if possible.
157 messages = messages + "Error, TMPDIR has changed ABI (%s to %s) and you need to either rebuild, revert or adjust it at your own risk.\n" % (abi, current_abi)
159 f = file(abifile, "w")
164 # Check the Distro PR value didn't change
166 distro_pr = data.getVar('DISTRO_PR', e.data, True)
167 prfile = data.getVar('SANITY_PRFILE', e.data, True)
168 if os.path.exists(prfile):
169 f = file(prfile, "r")
170 pr = f.read().strip()
171 if (pr != distro_pr):
172 # Code to convert from one ABI to another could go here if possible.
173 messages = messages + "Error, DISTRO_PR has changed (%s to %s) which means all packages need to rebuild. Please remove your TMPDIR so this can happen. For autobuilder setups you can avoid this by using a TMPDIR that include DISTRO_PR in the path.\n" % (pr, distro_pr)
175 f = file(prfile, "w")
181 # Check there aren't duplicates in PACKAGE_ARCHS
183 archs = data.getVar('PACKAGE_ARCHS', e.data, True).split()
185 if archs.count(arch) != 1:
186 messages = messages + "Error, Your PACKAGE_ARCHS field contains duplicates. Perhaps you set PACKAGE_EXTRA_ARCHS twice accidently through some tune file?\n"
190 raise_sanity_error(messages)
192 python check_sanity_eventhandler() {
193 if isinstance(e, bb.event.BuildStarted):
196 addhandler check_sanity_eventhandler