linux-kexecboot_git: update Zaurus defconfigs for 2.6.38-rc2
[openembedded.git] / recipes / readline / readline_4.3.bb
blob6d7902951c013dc18b07f5254edee6780c0f8421
1 DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
2 command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
3 additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
4 lines, and perform csh-like history expansion on previous commands."
5 SECTION = "libs"
6 PRIORITY = "optional"
7 LICENSE = "GPLv2"
8 DEPENDS += "ncurses"
9 RPROVIDES_${PN} += "readline"
10 LEAD_SONAME = "libreadline.so"
11 PR = "r5"
13 SRC_URI = "${GNU_MIRROR}/readline/readline-${PV}.tar.gz \
14 file://shlink-termcap.patch \
15 file://acinclude.m4"
16 S = "${WORKDIR}/readline-${PV}"
18 inherit autotools
20 do_configure () {
21 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
22 autotools_do_configure
25 do_install () {
26 autotools_do_install
27 # Make install doesn't properly install these
28 oe_libinstall -so -C shlib libhistory ${D}${libdir}
29 oe_libinstall -so -C shlib libreadline ${D}${libdir}
31 NATIVE_INSTALL_WORKS = 1
32 BBCLASSEXTEND = "native"
34 SRC_URI[md5sum] = "f86f7cb717ab321fe15f1bbcb058c11e"
35 SRC_URI[sha256sum] = "eeaf6f050b9f515b0636e5b4f2c153f9ef78e9061ee5dd74f612fab54c77bf88"