3 SRC_DIST_LOCAL ?= "move+symlink"
4 SRC_DISTRIBUTEDIR ?= "${DEPLOY_DIR}/sources"
5 SRC_DISTRIBUTECOMMAND[dirs] = "${SRC_DISTRIBUTEDIR}/${LIC}/${PN}"
7 # symlinks the files to the SRC_DISTRIBUTEDIR
8 SRC_DISTRIBUTECOMMAND-symlink () {
9 test -e "${SRC}.md5" && ln -sf "${SRC}.md5" .
13 # copies the files to the SRC_DISTRIBUTEDIR
14 SRC_DISTRIBUTECOMMAND-copy () {
15 test -e "${SRC}.md5" && cp -f "${SRC}.md5" .
19 # moves the files to the SRC_DISTRIBUTEDIR and symlinks them back
20 SRC_DISTRIBUTECOMMAND-move+symlink () {
21 if ! [ -L ${SRC} ]; then
22 src=`basename "${SRC}"`
25 if [ -e ${SRC}.md5 ]; then
27 ln -sf $src "${SRC}.md5"
32 #SRC_DISTRIBUTECOMMAND = "${@str(d.getVar('SRC_DISTRIBUTECOMMAND-%s' % d.getVar('SRC_DIST_LOCAL', 1), 1))}"
34 if d.getVar("SRC_DISTRIBUTECOMMAND", 1) is None:
35 cmd = d.getVar("SRC_DISTRIBUTECOMMAND-%s" % d.getVar("SRC_DIST_LOCAL", 1), 0)
37 d.setVar("SRC_DISTRIBUTECOMMAND", cmd)