python-paste: Add new recipe
[openembedded.git] / recipes / freesmartphone / illume-theme-freesmartphone_git.bb
blob1351674a1898e8e2d7afffecaf65965c81bc6c55
1 DESCRIPTION = "Illume theme for the freesmartphone.org project"
2 HOMEPAGE = "http://illume.projects.openmoko.org/"
3 LICENSE = "MIT/BSD"
4 DEPENDS = "edje-native eet-native"
5 PV = "0.1.0+gitr${SRCREV}"
6 PR = "r0"
8 SRC_URI = "${FREESMARTPHONE_GIT}/artwork.git;protocol=git;branch=master"
9 S = "${WORKDIR}/git/illume"
11 do_compile() {
12 cd illume && ./build.sh && cd ..
13 cd illume_init && ./build.sh && cd ..
14 cd illume-config
15 eet -e e.cfg config e.src 1
16 eet -e module.battery.cfg config module.battery.src 1
17 eet -e module.illume.cfg config module.illume.src 1
20 do_install() {
21 install -d ${D}${sysconfdir}/enlightenment
22 install -d ${D}${datadir}/enlightenment/data/themes/
23 install -d ${D}${datadir}/enlightenment/data/init/
24 install -d ${D}${datadir}/enlightenment/data/config/fso/
26 # Make fso the default profile
27 echo 'E_PROFILE="-profile fso"' > ${D}${sysconfdir}/enlightenment/default_profile
29 install -m 0644 ${S}/illume/fso.edj ${D}${datadir}/enlightenment/data/themes/
30 install -m 0644 ${S}/illume_init/fso_init.edj ${D}${datadir}/enlightenment/data/init/
32 install -m 0644 ${S}/illume-config/e.cfg ${D}${datadir}/enlightenment/data/config/fso/
33 install -m 0644 ${S}/illume-config/module.battery.cfg ${D}${datadir}/enlightenment/data/config/fso/
34 install -m 0644 ${S}/illume-config/module.illume.cfg ${D}${datadir}/enlightenment/data/config/fso/
37 RPROVIDES_${PN} = "illume-theme"
38 CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
39 FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
41 PACKAGE_ARCH_${PN} = "all"