python-paste: Add new recipe
[openembedded.git] / recipes / flickcurl / flickcurl_1.9.bb
blobea1cdb1974cbace12ad1d486bce92c296556a545
1 DESCRIPTION = "flickcurl is a C libarry for the Flick API"
2 SECTION = "libs"
3 HOMEPAGE = "http://librdf.org/flickcurl/"
4 LICENSE = "LGPL 2.1/GPL 2/Apache 2.0"
5 PR = "r0"
6 SRC_URI = "http://download.dajobe.org/${PN}/${PN}-${PV}.tar.gz"
8 DEPENDS = "curl libxml2"
10 EXTRA_OECONF = "ac_cv_func_vsnprintf=no"
12 inherit autotools
14 do_stage() {
15 install -d ${STAGING_INCDIR}
16 install -m 0644 ${D}/usr/include/*.h ${STAGING_INCDIR}
17 oe_libinstall -so libflickcurl ${STAGING_LIBDIR}
20 LEAD_SONAME = "libflickcurl.so.1"
22 FILES_${PN} += "${libdir}/libflickcurl.so.*"