1 DEPENDS += "gconf gconf-native"
4 if [ "$1" = configure ]; then
5 if [ "x$D" != "x" ]; then
8 SCHEMA_LOCATION=/etc/gconf/schemas
9 for SCHEMA in ${SCHEMA_FILES}; do
10 if [ -e $SCHEMA_LOCATION/$SCHEMA ]; then
11 HOME=/root GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` \
13 --makefile-install-rule $SCHEMA_LOCATION/$SCHEMA > /dev/null
20 if [ "$1" = remove ] || [ "$1" = upgrade ]; then
21 SCHEMA_LOCATION=/etc/gconf/schemas
22 for SCHEMA in ${SCHEMA_FILES}; do
23 if [ -e $SCHEMA_LOCATION/$SCHEMA ]; then
24 HOME=/root GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` \
26 --makefile-uninstall-rule $SCHEMA_LOCATION/$SCHEMA > /dev/null
32 python populate_packages_append () {
34 packages = bb.data.getVar('PACKAGES', d, 1).split()
35 pkgdest = bb.data.getVar('PKGDEST', d, 1)
38 schema_dir = '%s/%s/etc/gconf/schemas' % (pkgdest, pkg)
40 schema_re = re.compile(".*\.schemas$")
41 if os.path.exists(schema_dir):
42 for f in os.listdir(schema_dir):
43 if schema_re.match(f):
46 bb.note("adding gconf postinst and prerm scripts to %s" % pkg)
47 bb.data.setVar('SCHEMA_FILES', " ".join(schemas), d)
48 postinst = '#!/bin/sh\n'
49 pkgpostinst = bb.data.getVar('pkg_postinst_%s' % pkg, d, 1) or bb.data.getVar('pkg_postinst', d, 1)
51 postinst += pkgpostinst
52 postinst += bb.data.getVar('gconf_postinst', d, 1)
53 bb.data.setVar('pkg_postinst_%s' % pkg, postinst, d)
54 prerm = bb.data.getVar('pkg_prerm_%s' % pkg, d, 1) or bb.data.getVar('pkg_prerm', d, 1)
57 prerm += bb.data.getVar('gconf_prerm', d, 1)
58 bb.data.setVar('pkg_prerm_%s' % pkg, prerm, d)