cornucopia: bump SRCREV
[openembedded.git] / recipes / gtk-engines / elementary-icon-theme_2.3.bb
blob0cc1c95b9321f2b14d34f9f806c4439a1cc60204
1 DESCRIPTION = "Icon theme from the Elementary project"
2 SECTION = "x11/icons"
3 HOMEPAGE = "http://www.elementary-project.com/"
5 inherit gtk-icon-cache
7 # We have to get the icons from a mirror (LaunchPad) as DeviantArt has a download
8 # wrapper to stop simple HTTP gets :(.
10 SRC_URI = " \
11 http://launchpad.net/elementaryicons/2.0/2.3/+download/elementary-monochrome.tar.gz;name=mono;subdir=${BPN}-${PV} \
12 http://launchpad.net/elementaryicons/2.0/2.3/+download/elementary.tar.gz;name=regular;subdir=${BPN}-${PV} \
15 SRC_URI[mono.md5sum] = "986a2475e9953450b37912d154bb325d"
16 SRC_URI[mono.sha256sum] = "da461bd70b2fda633f26aa7495e1efc5d97815661799566f0a8accaea411272f"
18 SRC_URI[regular.md5sum] = "674a88984f55170c17298863f72dd34d"
19 SRC_URI[regular.sha256sum] = "f7cacfd0e4d3c9ea1c84b29a4f2c75fa1066d6c7f9b41ca0b96ae033c23992a6"
21 do_install() {
22 install -d ${D}${datadir}/icons/elementary/
23 install -d ${D}${datadir}/icons/elementary-monochrome/
25 cp -R ${S}/elementary/* ${D}${datadir}/icons/elementary/
26 cp -R ${S}/elementary-monochrome/* ${D}${datadir}/icons/elementary-monochrome/
29 FILES_${PN} = "${datadir}/icons/elementary*"
30 RDEPENDS_${PN} += "gnome-icon-theme"
31 PACKAGE_ARCH = "all"