cornucopia: bump SRCREV
[openembedded.git] / recipes / gpe-bootsplash / gpe-bootsplash_1.15.bb
blob7af263170c1719c9b11d74be96b9a314e8916e0c
1 inherit gpe
3 DEPENDS = "gtk+ libsvg-cairo"
4 SECTION = "gpe"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 PR = "r10"
9 SRC_URI += "file://splash-p.svg \
10 file://splash-l.svg \
11 file://init.patch \
12 file://no-strip-on-install.patch"
15 FILES_${PN} += "${datadir}/gpe"
17 do_install_append() {
18 install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-gpe-portrait.svg
19 install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-gpe-landscape.svg
20 mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S07bootsplash
23 pkg_postinst() {
25 update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg 10
26 update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg 10
29 pkg_postrm() {
30 update-alternatives --remove bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg
31 update-alternatives --remove bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg
34 SRC_URI[md5sum] = "205b47792c4adc4e1d07d6e4ce8cc466"
35 SRC_URI[sha256sum] = "586c4635a104e6566284d5edf5d64fbd6d944a92b5c1b493baf16e78db540060"