uclibc_git.bb: Bump to tip of git.
[openembedded.git] / recipes / uclibc / uclibc_git.bb
blob48088b080378726a22772c830fa0295f866008e4
1 # UCLIBC_BASE should be the latest released version of uclibc (that way
2 # the config files will typically be correct!) uclibc-svn takes precedence
3 # over uclibc-${UCLIBC_BASE}, if a config file in uclibc-snv is out of date
4 # try removing it
6 # UCLIBC_BASE can be set in a distro file, but whether this works depends
7 # on whether the base patches apply to the selected (SRCDATE) svn release.
9 UCLIBC_BASE ?= "0.9.31"
10 SRCREV="87c1f3f912593910b978b51d62f549e4dc32e8fb"
11 PR_append = "+gitr${SRCPV}"
12 DEFAULT_PREFERENCE = "-1"
13 #DEFAULT_PREFERENCE is 0 (empty), releases have a preference of 1 so take
14 # precedence.
16 require uclibc.inc
17 PR = "${INC_PR}.1"
18 PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
20 #recent versions uclibc require real kernel headers
21 PACKAGE_ARCH = "${MACHINE_ARCH}"
22 FILESPATHPKG =. "uclibc-git:uclibc-${UCLIBC_BASE}:"
24 #as stated above, uclibc needs real kernel-headers
25 #however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
26 KERNEL_SOURCE = "${STAGING_DIR_HOST}/${exec_prefix}"
27 SRC_URI = "git://uclibc.org/uClibc.git;branch=master;protocol=git \
28 file://uClibc.config \
29 file://uClibc.machine \
30 file://uClibc.distro \
31 file://uclibc-arm-ftruncate64.patch \
32 file://uclibc_enable_log2_test.patch \
33 file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch \
35 S = "${WORKDIR}/git"