weekly-changelog-report.py: add staging-branch
[openembedded.git] / recipes / musicpd / mpd_0.15.bb
blob8a8573fab9c86afa99624faf4588a16f0d34a605
1 DESCRIPTION = "Music Player Daemon (mpd)"
2 HOMEPAGE = "http://www.musicpd.org"
3 SECTION = "console/multimedia"
4 LICENSE = "GPLv2"
5 DEPENDS = "libvorbis libogg libao zlib libmikmod flac audiofile virtual/libiconv faad2 pulseaudio \
6 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag lame', d)}"
8 SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.bz2 \
9 file://mpd/mpd.conf \
10 file://mpd/mpd.init"
12 inherit autotools update-rc.d
13 INITSCRIPT_NAME = "mpd"
15 # Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
16 # be built, instead we use the OE built versions which should be installed
17 # in staging - remove the --with and replace with --enable to use the local
18 # versions.
20 EXTRA_OECONF = "\
21 --enable-ogg \
22 --with-id3tag-libraries=${STAGING_LIBDIR} \
23 --with-id3tag-includes=${STAGING_INCDIR} \
24 --with-mad-libraries=${STAGING_LIBDIR} \
25 --with-mad-includes=${STAGING_INCDIR} \
26 --with-faad-libraries=${STAGING_LIBDIR} \
27 --with-faad-includes=${STAGING_INCDIR} \
28 --disable-curl \
29 --disable-ffmpeg \
30 --disable-jack \
31 --enable-pulse \
32 --enable-mod \
33 --disable-oggflac \
34 --with-lame-includes=${STAGING_INCDIR}"
36 do_compile_prepend() {
37 find -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
40 do_install_append() {
41 install -d ${D}${sysconfdir}/init.d
42 install -m 755 ${WORKDIR}/mpd/mpd.init ${D}${sysconfdir}/init.d/mpd
43 install -m 644 ${WORKDIR}/mpd/mpd.conf ${D}${sysconfdir}/mpd.conf