weekly-changelog-report.py: add staging-branch
[openembedded.git] / recipes / libsndfile / libsndfile1_1.0.17.bb
blobeeedcb68a21ccb92d16477e01866488cae9e28fc
1 DESCRIPTION = "An audio format Conversion library"
2 HOMEPAGE = "http://www.mega-nerd.com/libsndfile"
3 AUTHOR = "Erik de Castro Lopo"
4 SECTION = "libs/multimedia"
5 LICENSE = "LGPL"
6 PR = "r2"
8 SRC_URI = "http://www.mega-nerd.com/libsndfile/libsndfile-${PV}.tar.gz \
9 file://configure-fix.patch;patch=1"
11 S = "${WORKDIR}/libsndfile-${PV}"
13 inherit autotools lib_package pkgconfig
15 do_configure_prepend_arm() {
16 export ac_cv_sys_largefile_source=1
17 export ac_cv_sys_file_offset_bits=64
18 ac_cv_sizeof_off_t=8
21 do_stage() {
22 oe_libinstall -a -so -C src libsndfile ${STAGING_LIBDIR}
23 install -m 0644 ${S}/src/sndfile.h ${STAGING_INCDIR}/
26 PACKAGES =+ "${PN}-octave"
27 FILES_${PN}-octave += "/usr/share/octave/site/m"