weekly-changelog-report.py: add staging-branch
[openembedded.git] / recipes / justreader / justreader_2.0k.bb
blobe05baf710f24d3020dc0f110f73c88787d199388
1 DESCRIPTION = "An E-Books reader for Qt/Embedded based Palmtop Environments"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 HOMEPAGE = "http://justreader.sourceforge.net/"
6 PR = "r3"
8 SRC_URI = "${SOURCEFORGE_MIRROR}/justreader/justreader_${PV}.tgz \
9 file://correct-settings-path.patch;patch=1 \
10 file://missing-include.patch;patch=1"
12 S = "${WORKDIR}/TextReader2"
14 inherit palmtop
16 EXTRA_QMAKEVARS_POST += 'INCLUDEPATH+="${STAGING_INCDIR}/qpe" LIBS+=-lqpe'
17 export OE_QMAKE_LINK="${CXX}"
19 do_configure_prepend() {
20 find . -name "Makefile"|xargs rm -f
23 do_install() {
24 install -d ${D}${palmtopdir}/bin \
25 ${D}${palmtopdir}/pics/${PN}/ \
26 ${D}${palmtopdir}/apps/Applications
27 install -m 0644 apps/Applications/justreader.desktop ${D}${palmtopdir}/apps/Applications/
28 install -m 0755 bin/justreader ${D}${palmtopdir}/bin/
29 install -m 0644 pics/* ${D}${palmtopdir}/pics/justreader/